Results 1 to 3 of 3
  1. #1

    stumped...raves not working?

    i ran my ski without the rave caps on because i felt that they werent opening all the way
    and when i removed them the ski ran much better, what i cant figure out is what is wrong with them
    im not sure if it is the diaphrams or the solenoid that opens them
    any help would be appreciated

  2. #2
    Electronics Guru Alpheus's Avatar
    Join Date
    Aug 2010
    Northern,VA, United States
    How long has it been since you took them out and cleaned them? They get pretty gunked up and start to stick. If not done so already,pull them out, give them a good cleaning and throw a couple of rebuild kits at them. Also check all of the lines and connections from the engine to the solenoid and to the RAVE's themselves. The zip ties tend not to hold them airtight after awhile.

  3. #3
    they have been cleaned, but i will rebuild and check everything else

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. One way check valve from crank to raves
    By Mtuned in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-19-2010, 08:34 PM
  2. Di vs non di raves
    By Slow 91 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 03-30-2010, 05:17 AM
  3. 787 raves
    By cardudenc in forum 2-Stroke Performance
    Replies: 7
    Last Post: 07-20-2008, 10:23 AM
  4. raves revisited
    By levonhelmet in forum 2-Stroke Performance
    Replies: 6
    Last Post: 09-11-2007, 11:58 PM
  5. Cleaning Raves
    By fdesorme in forum 2-Stroke Performance
    Replies: 4
    Last Post: 08-21-2007, 09:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts