Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Question 99 Polaris SLX 1050 problem

    I bought a 99 Polaris SLX1050 PWC about a year and a half ago, It has good spark on two of the three cylinders but the other one will only spark once when hit the starter and then nothing while it is cranking, if anybody knows what the problem could be please let me know, I tried to test the CDI and stator, i cant find any place that I can buy the update kit from either they tell me that it has been discontinued and is no longer available. And i cant find any used ones either. Another thing is if i switch the Black/White, Black/Blue, Black/Green wires around that run from the CDI to the coils i can get spark on all three. what would cause that, Thanks to any help.


  2. #2

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    John Zigler can get you one

    make sure you have atleast 10.6 volts while cranking or you won't get spark

  3. #3
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    Check the volyage when cranking likes lugs said. If you change the wires around, does the no spark follow a certain color wire?

  4. #4
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    The 99 update kit is not available. I tried to get one last fall. However, the 96-98 kit is the same electrically, the only difference being the stator cable exit from the flywheel housing. You could somehow adapt the cable to work with your current housing, or just get a housing from a 96-98 ski.

  5. #5
    john zigler's Avatar
    Join Date
    Aug 2006
    Location
    WI
    Posts
    2,545
    +1
    33
    try to take the plug boot off, and cut the wire back a 1/4 inch or so, to get into good wire.

    may also try switch plug boots from cyl to cyl, as these can go bad also.

  6. #6
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    35
    Quote Originally Posted by clay1191 View Post
    I bought a 99 Polaris SLX1050 PWC about a year and a half ago, It has good spark on two of the three cylinders but the other one will only spark once when hit the starter and then nothing while it is cranking, if anybody knows what the problem could be please let me know, I tried to test the CDI and stator, i cant find any place that I can buy the update kit from either they tell me that it has been discontinued and is no longer available. And i cant find any used ones either. Another thing is if i switch the Black/White, Black/Blue, Black/Green wires around that run from the CDI to the coils i can get spark on all three. what would cause that, Thanks to any help.
    The blk/white wire works with all 3 cylinders-switching that should cause no spark.
    The y/brn is for cyl #1 (mag/front cyl)
    blk/blue #2 -center
    blk/grn #3-rear cyl.

    What is the part # on your CDI?
    You said you tested the stator,does it pass all the tests?
    You can not test the CDI,but you need to test everything else.Check for a bad connection,including where the plug wires attach at the coil. Does your 1050 have an in-line connecter for the stator wires ?

  7. #7
    Quote Originally Posted by casey67 View Post
    The blk/white wire works with all 3 cylinders-switching that should cause no spark.
    The y/brn is for cyl #1 (mag/front cyl)
    blk/blue #2 -center
    blk/grn #3-rear cyl.

    What is the part # on your CDI?
    You said you tested the stator,does it pass all the tests?
    You can not test the CDI,but you need to test everything else.Check for a bad connection,including where the plug wires attach at the coil. Does your 1050 have an in-line connecter for the stator wires ?

    the P/N for the CDI is 4010885, I tested the stator last year, i dont remember but i wasnt quite sure how to test it. Does any body know if i can just use a stator and CDI from an earlier model. when i switched the three wires around as i mentioned before i had spark to all three cylinders while cranking, i didnt know that the y/brwn wire was for one of the coils, maybe ill have to check that out. also could a bad flywheel cause this because when i took it off it was pertty corroded i just cleaned it with electrical parts cleaner and emory cloth, thanks

  8. #8
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    35
    You have the updated ignition. (new style stator/CDI) These CDI's are programable. The update kit came with a new style stator(in 99 it was pretty much the 2000 model stator with the inline stator connecter) and a new style CDI,they used the 4010885 cdi and prgramed it for the 1050,it should have 447 written on it somewhere,the 447 means that is the new part # (4010447)

    You need to do these tests: http://www.greenhulk.net/forums/showthread.php?t=97491

  9. #9
    ​Yes the stator has the the in line connector I can't really figure out how to test it though

  10. #10
    What do you mean the CDI is programmable, how, I did notice tht it had a connector on it which looks like it could hook up to a computer cable

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New here, 1999 Polaris SLX 1050 problem
    By Chattanoogajack in forum Polaris Open Discussion
    Replies: 1
    Last Post: 10-10-2016, 10:51 AM
  2. WTB - Parts 99 polaris slx 1050 stator/cdi ignition upgrade
    By 450warrior in forum Polaris Classifieds
    Replies: 11
    Last Post: 04-14-2013, 04:30 PM
  3. polaris slx 1050 electrical problem
    By Voigta in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 12-22-2012, 10:17 AM
  4. 1999 Polaris SLX 1050 running problems
    By hunter2003k in forum Polaris Tech Tips and Info
    Replies: 6
    Last Post: 10-12-2012, 08:32 AM
  5. FS 99 Polaris SLX 1050 $1500
    By electricgeoff in forum Polaris Classifieds
    Replies: 2
    Last Post: 08-23-2011, 11:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •