Results 1 to 8 of 8

Thread: ok need help

  1. #1

    Join Date
    Jan 2011
    Location
    Bayside
    Posts
    20
    +1
    1

    ok need help

    so here is my story i have a 09 fzr with riva air induction,riva FF exhuast,R&D ride plate,intake grate, pump plug kit and ribbon has been removed,with these mods i was all over the limiter so i got my standard prop repitched to i think 12/22 the guy said,so now i'm not on the limiter as hard but top speed is down before it was about 76mph on the dreamo meter but now its down to bout 64mph.the guy who repitched my prop said that the wear ring had started to blister so would need a new one(wish he told me that before pump went back together) could that be my problem?or have i gone the wrong way with the repitch?any idea's or help would be much appreciated.


  2. #2
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    need a little more input, get a GPS....,,speedo is a no go.........need to know RPMs....how many hours....have you dinged the prop at some point...?

  3. #3

    Join Date
    Jan 2011
    Location
    Bayside
    Posts
    20
    +1
    1
    its got bout 90hrs on it,i know i need to get GPS number but wasnt really going to go down that path.the RPMs seem to be the same as before just not bouncing of the limiter as hard.i have noticed that lookin at prop and wear ring that the gap is not even all the way around prop will hit one side of the wear ring and a decent size gap on the other side.i might pull the prop out and check it see if it is dinged up but what i could see lookin at it in there it looked pretty good.

  4. #4
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,598
    +1
    4,805
    Dreamo-meter could be misleading you at least to a degree but sounds like you're way down. You need to get a GPS at this point so you can be somewhat accurate in your assessments. Let's see the blistering on the wear ring. Did you stray in to shallow water or ride your ski up on the beach? Did you suck up a ski rope, debris, shells, rocks, etc., etc.? Get under there and take a few pics of that impeller and wear ring and post them up; you say and it's hitting the ring maybe your mechanic needs to recheck his work.

  5. #5
    64physhy's Avatar
    Join Date
    Aug 2010
    Location
    Weatherford, TX
    Posts
    1,725
    +1
    168
    Dream-o-meter says you're going 12 MPH slower. Does it FEEL like you're going slower? Don't trust the stock speedo. I've seen mine say I was doing 10 MPH when I know I was doing around 50, and seen it say 80 MPH when I know I wasn't going that fast.

  6. #6
    Quote Originally Posted by 10*over View Post
    so here is my story i have a 09 fzr with riva air induction,riva FF exhuast,R&D ride plate,intake grate, pump plug kit and ribbon has been removed,with these mods i was all over the limiter so i got my standard prop repitched to i think 12/22 the guy said,so now i'm not on the limiter as hard but top speed is down before it was about 76mph on the dreamo meter but now its down to bout 64mph.the guy who repitched my prop said that the wear ring had started to blister so would need a new one(wish he told me that before pump went back together) could that be my problem?or have i gone the wrong way with the repitch?any idea's or help would be much appreciated.

    Your only doing 64mph after you re-pitched the prop? Definitely something wrong, you are slower than a standard FZR at top speed.

    Agree with most of the guys on here, I think you have maybe damaged your prop

  7. #7

    Join Date
    Jan 2011
    Location
    Bayside
    Posts
    20
    +1
    1
    Yeh i think the problem might be the damaged prop will pull it out and have a good look in the next few days and i might as well get the wear ring soughted and see if that will fix the problem.thanks for all the replys.

  8. #8
    FZS Monty's Avatar
    Join Date
    Apr 2011
    Location
    Eastern Long Island, NY
    Posts
    588
    +1
    37
    10* please be more specific in your posts. the more info you can provide the better. what do you mean by "i need to get GPS number but wasnt really going to go down that path" ? GPS are not expensive and easy to use......prop is sorta-kinda 12/22, what is it for sure? "decent size gap" measure it or take a picture.... pictures help a lot, videos as well.
    Pull the pump and take some pics.
    Send your impeller to a professional that will give you a true pitch.
    it will help you get better answers from here.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ok need help one last time about get her done
    By swafia in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 01-06-2012, 02:50 AM
  2. OK need computer help
    By mrjetskey in forum Polaris PWC Performance
    Replies: 10
    Last Post: 01-27-2009, 01:19 PM
  3. Need help in Tulsa, OK
    By emcewin in forum Yamaha PWC Performance (2-stroke)
    Replies: 18
    Last Post: 03-07-2008, 05:27 PM
  4. Ok Guys Need Help In Finding
    By duty in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 08-11-2007, 10:04 AM
  5. OK, need help with the small stuff now
    By Smitty in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 05-13-2006, 01:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •