Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1

    Rxp with x charger and other mods only revving out to 7100 prop ??

    i have a 07 rxp that i have recently done a few mods on the mods include x charger 42lb injectors 4" fizzle intake riva intake grate opas blocked freeflow exhuast and a 15/20 solas prop the
    my problem is ski is only revving out to about 7100 on the flat but when you take off or doing tight circles when the engine is under load ski revs to the limiter 8100 but soon is ski up on the plane the revs taper back to 7100ish when i go through chop etc the revs come up when ski bounces out of water
    my question is, is this 15/20 too big and not allowing engine from revving out the wear ring is stock but was in good gondition when i replaced the prop would a 14/19 be more suited to my setup or should i be looking for another problem
    cheers for any help


  2. #2
    hero's Avatar
    Join Date
    Feb 2011
    Location
    Australia sydney
    Posts
    331
    how many hours is on the x charger??..it should turn the 15/20 without any problem...

  3. #3
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Quote Originally Posted by hero View Post
    how many hours is on the x charger??..it should turn the 15/20 without any problem...
    +1, You have a problem somewhere for sure. I always start with a fresh set of plugs and go from there. Also maybe you have a boost leak?
    Did you purchase the prop brand new? If not, maybe someone has played with the pitch.

  4. #4
    i hate my bipolar disorder its great
    Join Date
    Nov 2011
    Location
    Melbourne - Australia
    Posts
    432
    +1
    9
    iv got 14/19 prop with x-charger fizzel intake block offs etc and it sits perfect at 8100rpm...

  5. #5
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    Without an ext ic a 15/20 might be too tall. Has it always revved out to 7100 or did you lose rpms?

  6. #6
    Swedish Viking Craigo's Avatar
    Join Date
    Jun 2008
    Location
    Seattle
    Posts
    1,367
    +1
    62
    Quote Originally Posted by Styler690 View Post
    ski is only revving out to about 7100
    This is the exact RPMs my RXT would top out at - before I had to replace the spark plugs at MudBug.

  7. #7
    Doel Tiburon1264's Avatar
    Join Date
    Nov 2007
    Location
    Jacksonville, Florida
    Posts
    2,343
    +1
    11
    Hi There!

    Check these items

    1. Boost Leak
    2. Change Spark Plug
    3. Slip on Sc
    Its running 8100 in chop conditions because is coming off hook!

  8. #8
    Ok all parts are new purchased from here just fitted this was first ride I replaced plugs also I have checked hoses etc for boost leak in stock form ski was fine rev to 8100 seems a bit strange that it will rev to limiter only when engine is under hard load will try stock prop to see what happens beening a brand new charger the slip should right or is it worth checkin cheers

  9. #9
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by Styler690 View Post
    Ok all parts are new purchased from here just fitted this was first ride I replaced plugs also I have checked hoses etc for boost leak in stock form ski was fine rev to 8100 seems a bit strange that it will rev to limiter only when engine is under hard load will try stock prop to see what happens beening a brand new charger the slip should right or is it worth checkin cheers
    Its possible as i have seen brand new chargers with bad slip...Do you have an external or interal ICer???If you have an external ICer then youll need a RRFPR as at WOT it is to lean and will not RPM out...

  10. #10
    Quote Originally Posted by Snoman View Post
    Its possible as i have seen brand new chargers with bad slip...Do you have an external or interal ICer???If you have an external ICer then youll need a RRFPR as at WOT it is to lean and will not RPM out...
    I am jus runnin stock intercooler will I still need a rrfpr I did check plug colour did look a bit lean

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Advice on my setup? 04 RXP with X-Charger and lots of goodies
    By trofodotiki in forum 4-Tec Performance
    Replies: 20
    Last Post: 07-01-2016, 05:50 PM
  2. 05 Rxp with x-charger and 48lb injectors questions?
    By Turbofab in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-21-2014, 11:24 AM
  3. Replies: 9
    Last Post: 01-17-2012, 04:50 PM
  4. Replies: 16
    Last Post: 08-21-2011, 09:22 AM
  5. what will rxpx impeller do in my 07 rxp with x charger and 42's?
    By bksbigboy69 in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-19-2011, 06:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •