Results 1 to 3 of 3
  1. #1
    cconigliaro's Avatar
    Join Date
    Oct 2011
    Boca Raton, FL

    05 R12-X Drops RPM and Boost on Top End

    When I'm full open on my ski, Sometimes it runs fine and other times the boost cuts and the rpms drop a little. It's driving me nuts!!! I watch the speedo go from 67 to 58 when this happens. I have no codes being thrown. I also am using the MacBoost module. Could the MAP sensor be seeing too much boost? If so, is there something that can be done for this. Can you put check valves inline to the MAP sensors? Any help is greatly appreciated.

  2. #2
    Join Date
    Jan 2008
    Currituck, North Carolina, United States
    Get a intercooler!

  3. #3
    jlfx car audio's Avatar
    Join Date
    Jul 2011
    jackson, TN
    Its getting heat soaked any added boost mods with stock IC will make this happen at some point . Add a intercooler kit from someone and problem solved or cut the macboost back down to a milder tune

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Gp1200r drops To 5,000 rpm
    By Almost in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 05-27-2011, 08:07 AM
  2. How much supercharger slip before RPM drops off?
    By cjo632racing in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-03-2011, 07:00 PM
  3. 99 SLTH - Top End Runs great, bogs down at low RPM
    By thiagoavila in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-29-2010, 12:02 PM
  4. rpm's o.k., lost top end
    By 2fast4me in forum 2-Stroke Performance
    Replies: 2
    Last Post: 05-09-2009, 07:33 PM
  5. Intermittent drops in rpm. Help?
    By engineermike in forum 4-Tec Performance
    Replies: 22
    Last Post: 07-04-2008, 02:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts