Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    indosurf's Avatar
    Join Date
    Oct 2011
    Location
    Caribbean
    Posts
    65
    +1
    1

    Blown Fuel Pump Fuse

    Took the ski out today for for my 2nd ride on it. It is a 2007 gtx limited with 22 hours purchased used.

    After about an hour of riding at moderate speeds and jumping small waves I was about a half mile from home when I gased it over a 4 foot wave, and landed flat and a lot harder than I wanted to. As soon as it landed the engine cut off. I first thought I had yanked out the key, but it was still in. I tried many times to restart it but no luck. There was a fishing boat right there that was heading back in and they gave me a tow.

    Onshore I found the 10 amp fuse to the fuel pump was blown. I replaced it with one of the spare 10 amp fuses and it blew immediately.
    Tried a 15 amp fuse and it fired right up. Took out the 15a and put back in a new 10a and its working fine.

    Could landing hard like that have caused the pump to jam-up?
    What should I check before heading back out?

    Sidenote: The ski has a 3" long crack in the plastic over the gauges. I am new to waverunners and just assumed they were still watertight even though I noticed what looked like some water stains on the gauges under the plastic, and the lcd was not working 100% maybe 80% (partial display of #'s and letters, like an F instead of an E), but now after today the gauge is displaying almost no info, so either the gauges got more wet, or the jolt from that landing finished it off.

    Could the fuel pump and gauge problem be related.

    Thanks


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    U need new guages for sure, and I would replace the fuel pump with a walbro 255 L/H, as well just to be sure it dosen't leave u stranded again.

  3. #3
    indosurf's Avatar
    Join Date
    Oct 2011
    Location
    Caribbean
    Posts
    65
    +1
    1
    Quote Originally Posted by psycho rxp View Post
    U need new guages for sure, and I would replace the fuel pump with a walbro 255 L/H, as well just to be sure it dosen't leave u stranded again.
    Arghhhhh! I wonder if i can send the guage cluster to seadoo for repiar. I live in the caribbean and there are no seadoo stealerships where i live. Does the guage have to be married to the craft? Not sure what all is required for that. I agree with you on changing the fuel pump.

  4. #4
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Does the guage have to be married to the craft? Not sure what all is required for that.
    For 07's it will need to be married to the ECU, I believe.

    I don't think seadoo will repair the dash, you'll have to buy another one. Some used ones show up here in the classifieds from time to time.

    Maybe wanna give Riva a call, and u may be able to send the ECU to them to be married to the new dash assy...

    Their # is 954-785-4820

  5. #5
    indosurf's Avatar
    Join Date
    Oct 2011
    Location
    Caribbean
    Posts
    65
    +1
    1
    Cool , thanks for their #

    Where should I get the fuel pump?
    How much do they cost approx?
    How much of a PIA is it to change out?
    Can i just run the ski with a dead instrument cluster?

    Thanks for your help!

  6. #6
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Quote Originally Posted by indosurf View Post
    Cool , thanks for their #

    Where should I get the fuel pump?
    How much do they cost approx?
    How much of a PIA is it to change out?
    Can i just run the ski with a dead instrument cluster?

    Thanks for your help!
    PM chris (slow 91)
    on here for the walbro pump.
    they aren't that hard to change out. there should be a few threads on fuel pump replacement. Should be under $100
    You probably could keep running it with the dead guages, as long as you can read fuel level, and maybe any warning messages that may pop up. Keep your oil, and coolant levels good tho.

  7. #7
    indosurf's Avatar
    Join Date
    Oct 2011
    Location
    Caribbean
    Posts
    65
    +1
    1
    Sweet! Thats some good news!

    If i get an instrument cluster is there a way that I can perform the wedding ceremony

  8. #8
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Quote Originally Posted by indosurf View Post
    Sweet! Thats some good news!

    If i get an instrument cluster is there a way that I can perform the wedding ceremony
    Yes, since you don't have a local dealer, your best bet would be to get a Can-doo pro kit,and doo it yourself, from the online store here:

    http://www.4-tecperformance.com/inde...x&cPath=18_166

  9. #9
    indosurf's Avatar
    Join Date
    Oct 2011
    Location
    Caribbean
    Posts
    65
    +1
    1
    Quote Originally Posted by psycho rxp View Post
    Yes, since you don't have a local dealer, your best bet would be to get a Can-doo pro kit,and doo it yourself, from the online store here:

    http://www.4-tecperformance.com/inde...x&cPath=18_166
    Thanks for your help!
    Just noticed your from PSL, I lived there for 5 years, great place!

    Is a Walbro 255 overkill for my stock set-up? Unfortunately I have no intentions of upping the boost

    Trying to find a part # for Summit's walbro 255 for seadoo's, are there different configurations or is it just a stock item?

  10. #10
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Quote Originally Posted by indosurf View Post
    Thanks for your help!
    Just noticed your from PSL, I lived there for 5 years, great place!

    Is a Walbro 255 overkill for my stock set-up? Unfortunately I have no intentions of upping the boost

    Trying to find a part # for Summit's walbro 255 for seadoo's, are there different configurations or is it just a stock item?
    I think seadoo only sells the pump as part of the sending unit assy. So the walbro is a direct fit replacement, that can also flow more than stock if needed, but will work just fine in a stock setup.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 11-01-2016, 02:53 AM
  2. 1999 Genesis blowing fuel pump fuse?
    By Taz man in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-26-2015, 11:17 PM
  3. HELP!! Blowing fuel pump fuse + flashing fuel level
    By cdes in forum Honda How To & FAQs
    Replies: 5
    Last Post: 08-01-2011, 07:22 PM
  4. Fuel pump blows fuse on key insertion.
    By FLSUN in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 02-26-2011, 07:58 AM
  5. fuse bolwn on fuel pump walbro require bigger fuse?
    By Daz RXT in forum 4-Tec Performance
    Replies: 7
    Last Post: 02-12-2011, 08:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •