Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    SLT 750 fuel guage not working

    Finally got my 95 SLT 750 restoration done and got it on the water. Runs awesome! Only issue is the fuel guage on the MFD reads empty and I get the flashing light. My question is if I have to replace the whole fuel sending unit or is it a simpler/less expensive fix? Thanks and I'll get pics up soon of the ski.


  2. #2

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    sounds like you need a new float contact John Zigler he has them

  3. #3
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30
    pull the sending unit out of the tank and inspect it, i have seen some that the wires where corroded and broken off in the tank.

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    If yours has the long silver tube, you most likely need the new float. Contact Zigler as noted above.

    If you have the old "arm and float" style, remove it and look to see if the wires came undone.

  5. #5
    Quote Originally Posted by xlint89 View Post
    If yours has the long silver tube, you most likely need the new float. Contact Zigler as noted above.

    If you have the old "arm and float" style, remove it and look to see if the wires came undone.
    I have the silver tube. So there is a float inside the tube? Not looking forward to it as that thing is a pain in the ass to get out.

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    It is a PITA to get out, but once out, you have just a tiny brass nut at the bottom of the sender to remove. The black plastic cover will come off, and the foam float will fall out.

    Install new float and new lockwasher and nut.

    DO NOT overtighten!!! The brass stud is easy to snap.

    Re-install tube. That's it.

  7. #7
    Quote Originally Posted by xlint89 View Post
    It is a PITA to get out, but once out, you have just a tiny brass nut at the bottom of the sender to remove. The black plastic cover will come off, and the foam float will fall out.

    Install new float and new lockwasher and nut.

    DO NOT overtighten!!! The brass stud is easy to snap.

    Re-install tube. That's it.
    Awesome, thanks! Contacted that Zigler dude and he has the floats for $30

  8. #8
    95 sl's Avatar
    Join Date
    May 2012
    Location
    appleton wi
    Posts
    83
    Ok so new here how exactly can I get a hold of john I have the same issue with the silver tube .... there is a another issue though maybe u guys can help Im probably going to need a new pump due to the last guy thinking he could epoxy the fittings back on but I still wanna use it just because I may need it some day thanks

  9. #9
    Pain is fear leaving your body.... rlovebk's Avatar
    Join Date
    Aug 2008
    Location
    So. Cal.
    Posts
    5,206
    +1
    511
    Here it is...
    www.watcom.com
    Also Rock County Jetski. Type it in and you'll find the site. He has prices and pics. Great guy. Reliable, honest, dependable.

  10. #10
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    Quote Originally Posted by rlovebk View Post
    Here it is...
    http://www.watcom.com/

    Also Rock County Jetski. Type it in and you'll find the site. He has prices and pics. Great guy. Reliable, honest, dependable.
    www.watcon.com

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SLT 700 -96 Fuel gauge not working
    By samitala in forum Polaris Open Discussion
    Replies: 0
    Last Post: 06-16-2008, 03:16 AM
  2. 2000 14.5 (TWINS) - fuel gauge not working
    By brdouglas in forum Sea Doo Sport Boats
    Replies: 3
    Last Post: 08-15-2007, 06:47 PM
  3. SLT 750 fuel tank in a '92 sl 650??
    By workaholic in forum Polaris Projects
    Replies: 3
    Last Post: 07-22-2007, 08:42 PM
  4. 94 slt 750 fuel question
    By ace16a in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-08-2007, 11:10 PM
  5. Fuel gauge not working?
    By mboley in forum Polaris Open Discussion
    Replies: 10
    Last Post: 04-25-2007, 09:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •