Results 1 to 6 of 6
  1. #1

    Replaced DFI Display As the the old one had nothing displaying still new one not work

    Hi I have a polars MSX 140. I bought a new dfi Display for it as the old one had nothing showing up. I have replaced it with the new one and still nothing is displaying. Could there be a fuse or something??
    Thank you


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Yes there is a fuse. I would have to look up where it is located on that model however.

  3. #3
    My fuse for my display is in the box with the coil pack, mounted on the terminal board.

  4. #4
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Looks like there should be a 2 amp fuse in a fuse block for the display.

  5. #5
    I can only find the one fuse where it says NGI. tested with the multi meter and its fine. any other opinions???

  6. #6
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Quote Originally Posted by mitch04 View Post
    I can only find the one fuse where it says NGI. tested with the multi meter and its fine. any other opinions???
    Thats the fuse you wanted.....Check to be sure there is power at the connector that plugs into the display.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. question about the new 150 speedster VS the old one
    By charles81076 in forum Sea Doo Sport Boats
    Replies: 8
    Last Post: 06-05-2012, 06:17 AM
  2. WTB worx grate for 08 rxtx the faster one not the cc one
    By STSPERFORMANCE in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 08-09-2011, 04:44 AM
  3. what are the best pistons to replace the stock ones for a ultra 250x?
    By madrui in forum Kawasaki PWC Performance (4-stroke)
    Replies: 13
    Last Post: 12-14-2010, 09:17 PM
  4. Replies: 11
    Last Post: 11-04-2006, 03:41 PM
  5. Once upon a time there was an old ski....know as the blaster
    By Mpeavler in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 01-15-2006, 10:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •