Results 1 to 5 of 5
  1. #1

    Join Date
    Sep 2011
    Location
    cincinnati, ohio
    Posts
    28

    battery discharging

    I just bought a 99 gp800 so I don't know a lot about it. The battery was dead when I brought the ski home, put in a new battery had to reset the security code and everything seemed to work ok. Didn't try to actually start it, just got it to turn over. Went back a few days later to try to start it and the battery was completely drained. Recarged battery and had to reset code to get it to turn over again. When I pulled the battery cable off the battery it arced so I know it was still pulling current even though it was turned off. Any suggestions on what is causing it to drain the battery, any insight would be greatly appreciated.


  2. #2
    I suffer from waverunneritis!!!! PWCManiac's Avatar
    Join Date
    Nov 2006
    Location
    Miami, Florida, United States
    Posts
    453
    This used to happen to me with ALL my waverunners. I wish I had an answer but I don't. My father has owned 3 boats & he always purchases the PERKO battery switches to prevent battery drainage because it happens to boats too.

  3. #3
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by riverbob View Post
    I just bought a 99 gp800 so I don't know a lot about it. The battery was dead when I brought the ski home, put in a new battery had to reset the security code and everything seemed to work ok. Didn't try to actually start it, just got it to turn over. Went back a few days later to try to start it and the battery was completely drained. Recarged battery and had to reset code to get it to turn over again. When I pulled the battery cable off the battery it arced so I know it was still pulling current even though it was turned off. Any suggestions on what is causing it to drain the battery, any insight would be greatly appreciated.
    If it's arcing you have a short somewhere.

  4. #4
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by PWCManiac View Post
    This used to happen to me with ALL my waverunners. I wish I had an answer but I don't. My father has owned 3 boats & he always purchases the PERKO battery switches to prevent battery drainage because it happens to boats too.
    Welcome back Alex have not seen you on the forum for a while.

  5. #5

    Join Date
    Sep 2011
    Location
    cincinnati, ohio
    Posts
    28
    Thanks PWCManic
    The problem with using battery disconnects is I have to reprogram the the security codes each time I hook the battery backup. Is this normal or do I have a problem in the gauge cluster?
    Another suggestion I had was that the rectifer is bad, has anyone had experience with this problem?
    I am just trying to find possible causes others have experienced with this problem before I tear into it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Battery Discharge Cutout Question
    By v8killah in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 06-21-2016, 10:31 AM
  2. 2004 polaris freedom no spark and battery is discharging
    By Allencool in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-29-2013, 11:05 AM
  3. Rxt-x 2008 problem discharge battery
    By carteknik in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 11-11-2011, 07:32 AM
  4. Replies: 5
    Last Post: 09-08-2011, 05:36 PM
  5. Battery discharge
    By J-ME in forum Honda Open Discussion
    Replies: 9
    Last Post: 04-22-2007, 08:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •