Results 1 to 7 of 7
  1. #1

    Join Date
    Feb 2012
    Location
    Perth Australia
    Posts
    4

    Smile Absolutly love my 300 BUT

    Hey guys i bought my ski just before christmas and wow what a machine,but @ 3-4 hours she wouldnt start,took back to dealer and starter motor and fly wheel had to be replaced, all good back out again then @12 hours it was free reaving so i idled back to shore took back to dealer from what ive been told the input shaft has come loose,has anyone heard of these problems before, ive been reading on forums how good everyones 300 is and reliable i just hope mine will be onced fixed

    Also does a LX seat fit on X model and where can you buy one from


  2. #2
    FullTilt429's Avatar
    Join Date
    Jul 2010
    Location
    Pleasanton, CA USA
    Posts
    332
    +1
    6
    First Ive heard of these issues, you must have gotten a Friday made boat... haha jk. Make a stink at the dealers and tell the you want a free extended warranty...or cintact Kawi direct and tell them. Those sound like semi-serious issues. Good Luck.

  3. #3
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Why did the starter motor and flywheel have to be replaced where they damaged ? Did something break ? That makes very little sense for such a new ski.

  4. #4

    Join Date
    Feb 2012
    Location
    Perth Australia
    Posts
    4
    Quote Originally Posted by FullTilt429 View Post
    First Ive heard of these issues, you must have gotten a Friday made boat... haha jk. Make a stink at the dealers and tell the you want a free extended warranty...or cintact Kawi direct and tell them. Those sound like semi-serious issues. Good Luck.
    ha ha i rekon she was built on friday beer o clock ,ive cracked the shits with em had it for 4 weeks and 2 of them where back in the shop see what happens now

  5. #5

    Join Date
    Feb 2012
    Location
    Perth Australia
    Posts
    4
    the clucth on the starter wasnt pushing the drive so it would spin then engage damaging the teeth on starter also slights markings on fly wheel,but i must say the mechanic they have is a good bloke and he tryin to help where he can

  6. #6

    Join Date
    Feb 2012
    Location
    Perth Australia
    Posts
    4
    Quote Originally Posted by sirbreaksalot View Post
    sounds like your dealer has 5 thumbs , casue if torqued to correct tension the shaft / flywheel cant come loose

    dealer error and probably bad diagnosis as well , bet it was a loose battery terminal lOl

    Waz
    Hey Waz battery all good mate, i think im just unlucky ha ha

  7. #7
    what's top speed?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I love my rxp but its doin my head in......
    By Karl Jackson in forum 4-Tec Performance
    Replies: 53
    Last Post: 09-12-2013, 02:34 PM
  2. MAN I LOVE MY xp BUT
    By lenfish in forum 2-Stroke Performance
    Replies: 7
    Last Post: 04-21-2011, 05:04 PM
  3. Love my new Pro 1200s but flood real easily
    By Picto in forum Polaris Open Discussion
    Replies: 11
    Last Post: 06-01-2010, 10:39 PM
  4. Replies: 8
    Last Post: 07-29-2008, 10:08 PM
  5. Got My $300.00 Gas Card
    By Dr Len in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-13-2006, 10:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •