Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 51
  1. #1
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198

    I stand corrected!!

    Yesterday I was pissed about my ski's performance & thought it was the riva grate adding brakes to the ride.

    Today at elsinore:
    72 degrees
    water 57 degrees
    flat water no wind.
    3 blade swirl pitched 13/17.5
    Riva grate
    stage 1 applied
    no holes filled yet
    reverse bucket cut.

    I got 71.1 mph @ 8100 bouncing off 8120 rpm on 3/4 tank.
    So I thought..."I think this riva grate is slowing me down", I roll in & put the stock grate on & head out.
    I get 8000 rpm @ 69.5 mph ..I'm like, Huh?
    I go back in & put the riva back on & go out again..
    At 1/2 tank & ran this speed at 8100 dead nuts!
    I am convinced the riva works now, I don't understand exactly why it out performed the stock grate in flat water but it did.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	ATT00049.jpg 
Views:	67 
Size:	15.8 KB 
ID:	14106  


  2. #2
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    Man fill those holes I put it off for weeks, went to Ace hardware and got a two part apoxy, it took 20 mins. Came back after a couple of hours hit what wasn't wiped clean when it was wet with wet sandpaper. BAM 1MPH Gain for 22 mins work and i'm anal so maybe 10 mins for a normal person..

  3. #3
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    Where did your prop recommendation come from? ... it's definitely a 3-blade... not a 4-blade?

    have you every tried a Solas 4-blade on your setup yet?

  4. #4
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    Thats 71.8 btw,
    So it gets better, I'm dickin' around & then I get to 1/4 tank & I'm gonna hit 72 mph....

    I hit the throttle & it fells strong & then my ski starts to bounce perty bad.
    I'm thinking I just lost my intake grate. Nope, one of the blades folded in half on the prop! It didn't do any damage to my already worn wear ring or pump thank god. I went straight to impros from the lake.

    When I had this swirl on before it was a 13/18 & only got me 68.x @ 8000 rpm so the 17.5 is the sweet spot for this prop. It pulled hard too! I now have my repitched stock prop back in & ready to go. It got me 71.4 with stock grate & stock pitch last time so I'm hoping for a good number. Thanx to Dave @ impro's For getting me set up on my props & the folded prop taken care of lickity split!
    That dude is baddass!
    Here's the water conditions today.
    Sorry for the cell cam quality.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	ATT00058.jpg 
Views:	77 
Size:	9.1 KB 
ID:	14109  

  5. #5
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    Quote Originally Posted by Shibby1485 View Post
    Where did your prop recommendation come from? ... it's definitely a 3-blade... not a 4-blade?
    3 blade all the way! A buddy of mine always told me about the 13/18 on the rxp is killer. He's right. He doesn't even own an rxp..
    After the initial run dave recommended 17.5

    Yes i've tried the 4 blade. 14/19r. I wasn't very impressed with it after feeling the pull of the 3 blade. I also thought the stock pulled better too.
    Last edited by ou812; 01-09-2007 at 09:02 PM.

  6. #6
    cool! I loved my three blade before it ate rocks ...PR...

    good numbers!

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Many people fail to realize this, but the Riva grate is faster than the stock grate. I refused to believe it too. Way back when i was running 77ish i felt maybe the Riva grate was holding me back. So i put my stock grate on and lost 3.7 mph. I figured something couldn't be right so i immediately went back to the landing and put the Riva grate back in and my 3.7 mph came back. Go figure!

  8. #8
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    yea same thing happened with my ski too.....def more speed with the riva grate!

  9. #9
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Good deal , I wont say I told you so, even though I just did
    Fill the holes= 1MPH

  10. #10
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    I'mma fill dem holes when I get back from the lake tomorrow for sure. I'm gonna run that stocker prop again.

    I guess the grate pulls the azz end down & lifts the front up 'eh? Less hull drag.

Page 1 of 6 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I stand corrected... Lord mother of God I was wrong...
    By Orangecrush in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 08-03-2015, 01:47 PM
  2. Stock Speedo correct!
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 14
    Last Post: 06-14-2006, 10:56 PM
  3. I can't stand it any longer....
    By lawracing in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-07-2006, 07:01 PM
  4. I know it's a stand up but.... 2006 SuperJet 760...
    By 11 in forum Yamaha Open Discussion
    Replies: 8
    Last Post: 01-30-2006, 05:26 PM
  5. Looking For PWC stand!
    By sprchrgd89gt in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-26-2005, 12:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •