Results 1 to 2 of 2
  1. #1

    Join Date
    Jan 2012
    Location
    fairfield twp., Ohio 45011
    Posts
    10

    2004 seadoo 3d blowing 5 amp fuse when trying to start

    I was trying to start my sea doo 3d 2004 model with low hours and nothing. It will instantly blow the 5 amp fuse. I am thinking that it is the component in the aluminum case called the computer or ecu? The wiring in the handlebars can be problematic I have been told and all checks out fine on that end. If it is the computer does anyone know where one can be had? I have looked with no luck so far on ebay. Thanks, Scott (513) 617-8029.


  2. #2
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    That 5 amp fues protects lots of things...It could be a start stop button or gauge, not just the mpem

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 03 gtx 4 tec makes a single click noise when trying to start
    By robbie02 in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-18-2013, 08:03 PM
  2. 2000 kawasaki 1100 stx di load pop when trying to start
    By moose1 in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 09-19-2010, 11:20 PM
  3. 2005 RXT clicks when trying to start...
    By KeithKman in forum 4-Tec Performance
    Replies: 21
    Last Post: 09-18-2009, 09:39 PM
  4. 04 Seadoo RXP Clicks when trying to start??
    By cfillingi in forum Sea Doo Open Discussion
    Replies: 65
    Last Post: 08-04-2009, 10:23 AM
  5. just a click when trying to start
    By 2kids3pets in forum Polaris Open Discussion
    Replies: 10
    Last Post: 06-29-2009, 07:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •