Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 56
  1. #1

    Join Date
    Jan 2012
    Location
    Weston, Fl
    Posts
    23

    Question Loss of Power...

    I have an rxp 2005 which i took out to the water this Friday, the engine started great, i let it heat up for a while and then i gunned it by the canal,
    i got to 72 no problem and then i turned back to the dock to pick someone up and on my way back i lost all power, my top speed was probably 40...
    i lost all power, so i took it out of the water to make sure i didn't suck anything up the grate and nothing....

    anybody any suggestions?


  2. #2
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196
    Have you replaced your supercharger washers? Just asking since this is your first post. Or it could be as simple as a boost leak. Hose clamp.. do us a favor pull the hose from the supercharger to the throttle body off and try to spin the supercharger with your finger. What do you have done to your ski modification wise.Good luck and welcome to the forum.

  3. #3

    Join Date
    Jan 2012
    Location
    Weston, Fl
    Posts
    23
    the washer where changed a while back, and it has a riva stage one kit, i check all the clamps out on markham before i left and they where all on but i'll do what you just told me, thanks and thanks for the welcome!

  4. #4
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196
    Quote Originally Posted by Scotland View Post
    the washer where changed a while back, and it has a riva stage one kit, i check all the clamps out on markham before i left and they where all on but i'll do what you just told me, thanks and thanks for the welcome!
    New metal washers fail as well.

  5. #5

    Join Date
    Jan 2012
    Location
    Weston, Fl
    Posts
    23
    how would i know if the washers are gone? im new to the jetski, it belonged to a family friend and he had to leave the country and just gave it to me, ive had it for almost 3 months now and this is the first time i've had a problem with it... what should i be looking for?

  6. #6
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196
    Quote Originally Posted by Scotland View Post
    how would i know if the washers are gone? im new to the jetski, it belonged to a family friend and he had to leave the country and just gave it to me, ive had it for almost 3 months now and this is the first time i've had a problem with it... what should i be looking for?

    Well if you can turn the Supercharger wheel by hand you have lost your washers. If you have a stage 1 then you would remove your three inch air induction to the supercharger.

    I see you stated Markham (Weston,FL) You wouldn't happen to be the guy out a few weeks ago on a green rxp. When i was there testing and that race boat was there (114mph boat)? If so. That thing didnt sound right that day as well

  7. #7
    HardmanGT's Avatar
    Join Date
    Aug 2009
    Location
    Rutherfordton, NC
    Posts
    459
    +1
    3
    What was the max RPM after you lost power? If you are somewhere around 6500 RPM then you either have a boost leak or a supercharger issue. The ski will not be able to climb above that without the extra kick from the supercharger.

    If you are redlining the engine and the ski tops out around 40mph then you have an issue with the drive, most likely something got sucked up into the impeller and is causing cavitation in that case.

    Give us more info and we can guide you on to the next step

  8. #8

    Join Date
    Jan 2012
    Location
    Weston, Fl
    Posts
    23
    that might of been me in markham that day, but there was something wrong that day, i had the supercharge hose clamp off (didnt even noticed when i took it out, so i got it a new one and changed that and that fixed the sound problem)

  9. #9

    Join Date
    Jan 2012
    Location
    Weston, Fl
    Posts
    23
    alright so i just opened her up, checked the sc with my fingers and i couldn't move it at all, i re-tightened all the hose clamps and ran her while on a hose and it worked no problem, any other suggestions before i take her out into the water for a test? (rechecked the intake grate and the impeller nothing inside of them) (small update it has riva stage 2 but no stage two intake grate, it has oem)

  10. #10

    Join Date
    Jul 2009
    Location
    Uk
    Posts
    251

    like he said

    Quote Originally Posted by HardmanGT View Post
    What was the max RPM after you lost power? If you are somewhere around 6500 RPM then you either have a boost leak or a supercharger issue. The ski will not be able to climb above that without the extra kick from the supercharger.

    If you are redlining the engine and the ski tops out around 40mph then you have an issue with the drive, most likely something got sucked up into the impeller and is causing cavitation in that case.

    Give us more info and we can guide you on to the next step
    like he said rpm max before and after?
    fault codes?
    limp mode?

Page 1 of 6 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss Of Power/RPM Drop
    By ph2ocraft in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-26-2007, 12:44 PM
  2. '04 GTX 4 Tec Loss of Power
    By coach mike in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-24-2007, 10:31 PM
  3. loss of power ( Max rpm 7000 ) after 7 hours
    By LAB69 in forum 4-Tec Performance
    Replies: 34
    Last Post: 04-02-2007, 04:59 PM
  4. 96 sl900 loss of power
    By scorp in forum Polaris Open Discussion
    Replies: 11
    Last Post: 01-08-2007, 07:18 PM
  5. Loss of power 04 RXP
    By PossisRXP in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 05-14-2006, 06:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •