Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Join Date
    Feb 2012
    Location
    Ohio
    Posts
    132
    +1
    7

    Has Anyone Disabled The KSS On 300X?

    My first post... My very first ride on my 300X had me pitched off @ +50MPH! I also have a 98' 1100 STX and expected nothing to happen when I let off the throttle. To my unhappy surprise the 300X went one way, and my body kept going straight... I NEVER want the machine thinking for me in in that regard ever again. I have the Service Manual, and am considering just removing the magnet on the steering arm that activates the sensor. Thoughts?


  2. #2
    gmoeller's Avatar
    Join Date
    Nov 2007
    Location
    Hermosa Beach, Calif
    Posts
    1,450
    +1
    9
    Yep, I HATE that stupid thing - it drives me nuts. I need to disconnect mine also. Mine can Re-accelerate after deceleration up to 4 or 5 times.....Talk about dangerous for beginners.

  3. #3
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Quote Originally Posted by Speed Jones View Post
    My first post... My very first ride on my 300X had me pitched off @ +50MPH! I also have a 98' 1100 STX and expected nothing to happen when I let off the throttle. To my unhappy surprise the 300X went one way, and my body kept going straight... I NEVER want the machine thinking for me in in that regard ever again. I have the Service Manual, and am considering just removing the magnet on the steering arm that activates the sensor. Thoughts?
    I'm sorry but it does not activate at that speed. And only activates when u let off the gas and turn the handles bars sharply. so y would u ever turn the bars at 50 and let off the gas.? My bet is you got pitched off by the rapid deceleration that the stock intake grate provides. And to answer your question u can just unplug it

  4. #4

    Join Date
    Feb 2012
    Location
    Ohio
    Posts
    132
    +1
    7
    Thanks, and I have read those threads. I was hoping to not just leave wires disconnected, and not protected from the "elements". I can obviously work that out unless anyone knows where the plug mates can be found? It's that particular reason why I was thinking about just removing the sensor actuator (magnet).

    I'm certainly no racer, but as I said earlier I've owned a JetSki since '98... My mistake was believing/understanding that turning/manipulating the handle bars with the throttle released wouldn't have such a consequence. I agree the sudden decelleration was surprising, BUT I'll butcher a quote from Regge Fountain by saying it should/is ALWAYS okay to decrease throttle when the situation is dangerious... Having the ECU decide my intention was to steer was ALMOST catastrophic... Coming off the JetSki @ +50 I lost a ball cap, sunglasses, 1 shoe, shorts, and obviously lots of pride with my friends watching me on my new high powered toy! Although I haven't made THAT mistake again, I have had the throttle applied again unexpectedly, and from where I sit that is NEVER a good thing!

  5. #5
    Self Confessed Day Dreamer toomanytoys's Avatar
    Join Date
    Sep 2008
    Location
    Sydney, Australia
    Posts
    1,932
    +1
    151
    Mine is disconnected on my STX-R (only because it's got too many mods). I only ever noticed the STX-R's one come on if I moved the bars while flushing (specifically when bliping the throttle at the end).

    I've never, in 45 hours, felt the Ultra 300X's KSS come on. It doesn't trigger out of the water like the STX-R does either (I've tried). At saying that, without actually trying to make it come on in the water, which I haven't done, I don't see an issue with it?

    Maybe mine is broken, I'll check it when I'm out next, but I doubt it.

  6. #6

    Join Date
    Feb 2012
    Location
    Ohio
    Posts
    132
    +1
    7
    [QUOTE=no_more_rice;1877867]I guess you better unplug it so you can keep your pants on

    Well at the risk of TMI they weren't lost just at my ankles... Thanks for taking it easy on this "first timer". It was without a doubt my mistake from inexperience with this particular toy. As I have said m MANY times as I allow others to use my toys. "Just remember, it can get you in a whole lot more trouble than it can get you out of..."!

    Guess I'll figure out how to protect the plug ends after I disconnect them... THANKS AGAIN!!!

  7. #7
    Pain is fear leaving your body.... rlovebk's Avatar
    Join Date
    Aug 2008
    Location
    So. Cal.
    Posts
    5,206
    +1
    511
    Quote Originally Posted by FIRE0021 View Post
    I'm sorry but it does not activate at that speed. And only activates when u let off the gas and turn the handles bars sharply. so y would u ever turn the bars at 50 and let off the gas.? My bet is you got pitched off by the rapid deceleration that the stock intake grate provides. And to answer your question u can just unplug it
    Yep. I believe this guy. Please be careful. You can put waterproof grease around it and then wrap it up real good with electical tape.

  8. #8
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Quote Originally Posted by FIRE0021 View Post
    I'm sorry but it does not activate at that speed. And only activates when u let off the gas and turn the handles bars sharply. so y would u ever turn the bars at 50 and let off the gas.? My bet is you got pitched off by the rapid deceleration that the stock intake grate provides. And to answer your question u can just unplug it
    +1

    It only revs to around 3000 rpms.....

    And I believe the Fountain guy you are refering to was talking about boats...they will still turn some what with out power applied...a jet ski will NOT turn with out power....on a jet ski...."when in doubt dont let out".......

  9. #9
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Speed jones lets say hypothetically it did engage at 50mph witch I'm pretty sure it did not. But how would this cause you to get thrown from the ski ? The rpm that it would rev to would not cause the ski to go any faster so how did you get thrown what where you doing when it happened. ?

  10. #10

    Join Date
    Feb 2012
    Location
    Ohio
    Posts
    132
    +1
    7
    In all honesty I can't tell you exactly what happened other than the JetSki pitched me unexpectedly. First of all it happened back in May ('11), and I've slept a lot since then... As I've said I've owned a JetSki for many years, and surely understand the need for power to turn...

    The story goes like this: I was breaking the motor in when I heard a "loud & proud" power boat coming up on my right side. Because I wasn't interested in pushing the motor hard (yet), I chose to let off the throttle and turn away from the boat. As I throttled to effect my turn the JetSki was suddenly going sharply left, and my big ass (+240 Lbs) was going straight. I remember skipping on my back for long enough to think "damn I hope I don't hit anything...". The wreck was so spectacular that the complete strangers in the power boat came back to check on me... Other than a knot on my left hand from the switch assy on the handle bar, I was for the most part no worse for the wear. The JetSki was +40 yards away from where I stopped. Now I have no problem accepting that the "twitchy" nature of the throttle on this machine just might have been my problem here... BUT I have had the KSS apply itself when I didn't expect it... So regardless of the particular reason for THAT embarrassing moment, I'm sure that the ECM making decisions without the benefit of my vision/decisions is not a feature I'm willing to subject myself or for that matter anyone who rides this toy. The friends of mine that are THAT inexperienced on JetSki's can ride the 1100 STX...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I would like to disconnect the KSS on my 2013 300x Does anyone have photos of plug?
    By rod_rod in forum Kawasaki PWC Performance (4-stroke)
    Replies: 15
    Last Post: 10-15-2015, 02:58 PM
  2. has anyone trimmed the syphon tube on there sho?
    By wave15stx in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 08-20-2010, 09:17 PM
  3. Has anyone painted the trim on their Sea Doo, and had it last?
    By Mike94ZLT1 in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 08-15-2009, 07:40 PM
  4. Has anyone put the RXT(X) on a closed course
    By T5Racing in forum 4-Tec Performance
    Replies: 8
    Last Post: 04-09-2009, 03:38 PM
  5. Has Anyone Tried the Hydroturf Name in Lime Green on a RXP
    By thompsdw in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 02-25-2009, 06:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •