Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    jetski running on river or lake still needs flushing?

    ??


  2. #2
    Almost's Avatar
    Join Date
    May 2010
    Location
    Cape May, NJ
    Posts
    778
    +1
    73
    I would say yes. Even though it's not salt water there is definitely traces os salt or some chemicals from runoff that are acidic.

  3. #3
    Lightning Struck's Avatar
    Join Date
    May 2011
    Location
    Davenoprt Iowa
    Posts
    714
    +1
    10
    Definitely! There's all sorts of bad stuff in lakes and rivers

  4. #4
    River water which is neAr the ocean mayvbe backish, and contain alot of salt.

    Clean, salt free lake water is a bit different. Althugh the manufacturers will certainly advise you to flush after riding, it often is not mandatory.

    I run a 100+ hoursa year and do not flush my skis regularly. My old two strokes have many years and countless hours on them. I never flush them, I either pull them on a lift to sit till the next ride, or sometimes just let them sit in the water tied to the boat or dock. My old xp spent 11 seasons like that, although it was ridden 5 days out of the week.

    The VXS has 130+ hrs and lives at the lake on a lift, we will see how it holds up.

    This is just my experience owning pwcs for the last 25 years and should be taken for what its worth.

  5. #5
    Btw, there are about 20 pwcs at our marina on lifts. I have never seen anyone flush any of them at the end of the day.

    The only ones that are ever broken, or seem to have any issues are the Kawsaki 4 strokes, and i am not sure that is related to the lack of flushing.

  6. #6
    Quote Originally Posted by dukenyc View Post
    Btw, there are about 20 pwcs at our marina on lifts. I have never seen anyone flush any of them at the end of the day.

    The only ones that are ever broken, or seem to have any issues are the Kawsaki 4 strokes, and i am not sure that is related to the lack of flushing.
    thanx

  7. #7
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,581
    +1
    4,795
    Quote Originally Posted by dukenyc View Post
    The only ones that are ever broken, or seem to have any issues are the Kawsaki 4 strokes, and i am not sure that is related to the lack of flushing.
    Nope, it's a Kawi thing....

  8. #8
    JKR1300's Avatar
    Join Date
    Jan 2006
    Location
    St Louis & 6mm LotO
    Posts
    497
    +1
    6
    No

  9. #9
    YAMAHA POWAAAA !!!!! 1_Fast_SHO's Avatar
    Join Date
    Apr 2010
    Location
    Houston, Texas
    Posts
    3,144
    +1
    255
    Quote Originally Posted by YoYamma View Post
    Nope, it's a Kawi thing....
    jajaajaj AGREE

  10. #10
    kyvxr's Avatar
    Join Date
    Aug 2011
    Location
    Central Kentucky
    Posts
    31
    I only ride fresh water & the only time my skis see a hose is when I change the engine oil or winterize/de-winterize. No issues here, been doing that since 1992.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. XLT 1200 Need Advice on ignition or carb issues. Rough running
    By swift53 in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 02-20-2013, 01:31 PM
  2. 1995 waveraider 1100 runs on land or hose but not in water
    By mularski2 in forum Yamaha ECU Support
    Replies: 2
    Last Post: 07-13-2010, 01:32 AM
  3. Chickahominy & James River Run on June 30
    By JAG in forum Southeast
    Replies: 3
    Last Post: 06-29-2007, 12:51 PM
  4. Replies: 1
    Last Post: 06-25-2007, 09:49 AM
  5. Replies: 4
    Last Post: 06-20-2007, 07:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •