Results 1 to 9 of 9
  1. #1

    1995 Polaris SL750 Restore/Paint

    Hello everyone!
    My name is Seth Arterburn, I recently purchased a 1995 Polaris SL750 from a man in Gainsboro Tennessee for a measly $450! The trailer is in great shape and so is the ski. I am working on restoring this ski to perfect condition. My uncle owns a body shop and is going to help me with the body work. There is a small spot on the rear corner that needs a little fiberglass help. I will post more pics when I get home. I have already stripped down the MFD and cleaned the contacts and replaced the factory buttons on the front with more stable, sturdier buttons made for more rough pressing. The SET button was an open circuit so I replaced them both. The electrical box is another thing I will work on eventually but my current chore is to replace ALL of the fuel system. I have talked to John Zigler and he is gonna hook me up with an entire new system to slap in there. Going with a triple output fuel pump and some new lines along with a new selector. It is already converted over to premix, but I have to build something to hold the spring for the hood so I can take out the useless tank. I will post my questions along with my pictures as soon as I get home to my project Ski.

    Thanks guys
    Click image for larger version. 

Name:	IMG_0273.jpg 
Views:	212 
Size:	93.8 KB 
ID:	264048Click image for larger version. 

Name:	IMG_0272.jpg 
Views:	112 
Size:	150.7 KB 
ID:	264047


  2. #2
    ThrottleOut's Avatar
    Join Date
    Aug 2011
    Location
    Corning, NY
    Posts
    727
    +1
    29
    Awesome, looks like it'll be a fun project! Sounds like you're on the right track with the fuel system upgrades as well. Make sure you read up on piston wash so you can get the tuning dialed in when you get it all up and running.

  3. #3
    Got the polaris cleaned finally! got a new intake cover on it and cleaned alot on it. Took it out on the water yesterday and it ran well but never got over 4400 rpm. Anybody know what the problem could be?

  4. #4
    johnsonmtz's Avatar
    Join Date
    Oct 2006
    Location
    Mt. Zion Illinois
    Posts
    1,250
    +1
    7
    Quote Originally Posted by setharterburn View Post
    Got the polaris cleaned finally! got a new intake cover on it and cleaned alot on it. Took it out on the water yesterday and it ran well but never got over 4400 rpm. Anybody know what the problem could be?
    Seth,
    Did you happen to do the body work yet? The reason I ask is these hulls were SMC, not fiberglass. Standard polyester resin (uses MEK hardener) will not bond well to this material. You really need to use slow cure, 2-part epoxy for repairs on these hulls.

    Look over all the obvious things on the low RPM and do not run the ski at WOT until you find and correct the problem. Make sure fuel vents are clear, check high speed needle settings, make sure there are no obstructions in the carb filters and jets. You can use the OEM high speed jets with free flowing F/A's but you need to turn the high speed needles out an extra 1/2 turn to compensate for the increased air flow.

    The 4400 RPM limit sure sounds like the CDI causing it. In the '95 Models, the MFD is suppose to show warnings for low oil, overheating, and low fuel. For the 750 skis, you just got the red light and maybe info on the display. On the '95SLX 780 you got the same warnings, but it also would limit the RPM to 4200 if a warning condition existed. If the fuel system checks out okay, I'd be suspicious that maybe a CDI from an SLX780 has been swapped into this ski and you have a warning light that is tripping the RPM limit.

    KJ

  5. #5
    well I actually took care of that problem by zip tying the floater in the oil tank up to the top. Fuel pump works fine and jet ski seems to work finally (electronically speaking.) The ski will not idle. It seems as though maybe it is starving for fuel or has gummy carbs. After it is planed out, it will top off at 4400 and ride smooth, but it wont do anymore than that. The MFD is working fine, fuel tank, oil tank, and trim are all working fine. The problem seems like it is an actual engine issue.

  6. #6
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30
    Quote Originally Posted by setharterburn View Post
    well I actually took care of that problem by zip tying the floater in the oil tank up to the top. Fuel pump works fine and jet ski seems to work finally (electronically speaking.) The ski will not idle. It seems as though maybe it is starving for fuel or has gummy carbs. After it is planed out, it will top off at 4400 and ride smooth, but it wont do anymore than that. The MFD is working fine, fuel tank, oil tank, and trim are all working fine. The problem seems like it is an actual engine issue.

    quit running that thing until you get the fuel system upgrade! replace all the lines from the tank to the fuel pump, rebuild the carbs, get youre carbs settings right new lines new lines new lines!! trust me you DONT want to do damage to youre engine! I blew up a cylinder/piston...400 dollars later its running again!

  7. #7
    johnsonmtz's Avatar
    Join Date
    Oct 2006
    Location
    Mt. Zion Illinois
    Posts
    1,250
    +1
    7
    That ski should be turning 6250 RPM at wide open throttle. You have a big problem that must be solved if you're only getting 4400 max. Like vampire said, you need to solve this problem before you ride the ski anymore. If keep riding you run the risk of the engine going boom and costing a bunch more money.

  8. #8
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Have you done compression tests yet?

  9. #9
    Thread closed. Mag cylinder had a huge hole in the piston. Major issues with the fuel. Traded it for a gun and 100 bucks. Any recommendations for a new ski?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1995 Polaris SL750
    By LadyStarryEyed in forum Polaris PWC Performance
    Replies: 34
    Last Post: 12-31-2008, 12:49 AM
  2. 1995 Polaris SL750's
    By SCFirestopper in forum Polaris Open Discussion
    Replies: 14
    Last Post: 08-09-2008, 06:37 PM
  3. Replies: 0
    Last Post: 09-27-2007, 03:54 PM
  4. 1995 Polaris sl750 Bilge pump question .
    By smittyj77 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 05-29-2007, 12:47 AM
  5. Newbie who purchased a 1995 Polaris SL750 and have some questions
    By Great_Outdoors_5911 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-18-2007, 10:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •