Results 1 to 3 of 3
  1. #1

    Polaris msx 110 check engine

    Hi I have a msx 110turbo that starts and runs beautiful but when I go to gas it it goes into limp mode and the check engine light flashes, anyone got any clues on how I fix this problem , very frustrating problem put the ski in the shed last summer running fine take it out of the shed and for no reason this problem occurs . Any help with this would be greatly appreciated. Thanks . It's a 2004 model as I'm only a new member it would be great for some advise my first ski and question so double virgin.
    Last edited by Greg63; 02-19-2012 at 06:00 AM. Reason: More info

  2. #2
    Kosh's Avatar
    Join Date
    Sep 2007
    Welcome Greg,

    Check your waste gate for seizure this is a common fault if it is not regularly lubricated. Do a search as there is already a lot of information on how to get it working.

  3. #3
    Thanks Kosh will do

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. '04 MSX 110 Check Engine Light
    By desertracer695 in forum MSX/Matrix
    Replies: 0
    Last Post: 08-09-2011, 09:58 PM
  2. Check engine light reset for a polaris 2003 msx
    By jjlegare in forum MSX/Matrix
    Replies: 0
    Last Post: 07-13-2011, 09:10 PM
  3. FS O2 oxygen sensor 0451353 for Weber engine (MSX 110, MSX 150)
    By K447 in forum Polaris Classifieds
    Replies: 3
    Last Post: 12-01-2010, 07:36 PM
  4. 04 Polaris MSX 110
    By sidekick2606 in forum MSX/Matrix
    Replies: 1
    Last Post: 05-06-2010, 10:27 PM
  5. Polaris MSX 110-HELP
    By seahawks1 in forum MSX/Matrix
    Replies: 1
    Last Post: 07-14-2009, 04:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts