Results 1 to 4 of 4
  1. #1

    Join Date
    May 2009
    Location
    Broadstairs, Kent, England
    Posts
    138
    +1
    2

    Impeller boot 0'4 RXP

    I was stripping my jet pump down yesterday (damn those bolts were corroded into the jet pump assembly) and noticed that where the driveshaft connects to the impeller the joint is completely dry, no grease whatsoever. I assume the rubber o-ring hasn't been sealing on the drive shaft. I think mine might have an aftermarket connector, it's green and looks anodised (it screws into the impeller with a quite a coarse reverse thread). I don't know if I have an upgraded impeller on my ski, I haven't fitted one but the previous owner had added an Aquavein grate, Riva intake, thru hull exhaust and blow off valve - so perhaps he would have upgraded the impeller too? If it is an upgraded impeller, can I go back to the standard Seadoo boot? I guess this would also be a good time to ask how I can tell if I have an upgraded impeller! I can't see any markings on it but I'm probably not looking in the right place.

    Thanks in advance... Adrian


  2. #2
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    You got a pic?
    Is the prop polished finish (solas) or dull (OEM)?
    your nose cone is a solas so good chance prop is solas as well.

  3. #3

    Join Date
    May 2009
    Location
    Broadstairs, Kent, England
    Posts
    138
    +1
    2
    I'm away for the week but will post a pic next weekend. The prop is actually dull from memory, it's definitely not polished. If I do have a solas boot thingy should I order a new one, to hopefully make a better seal?

    A.

  4. #4
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    No matter what nose cone you run water will still get to the driveshaft splines.
    I would just use the solas if the o ring is still good.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP Impeller boot comes off
    By bluestram in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-09-2015, 09:00 AM
  2. 2004 RXP impeller Boot check it out.
    By jdmctr in forum 4-Tec Performance
    Replies: 4
    Last Post: 10-07-2011, 08:49 AM
  3. Metal Impeller Boot for RXP-X
    By Water Pig in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 09-16-2008, 02:53 PM
  4. Need new impeller for a stock RXP
    By THEGOAT in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-30-2008, 11:01 AM
  5. Impeller to pump clearance - RXP
    By Vern in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-03-2007, 09:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •