Results 1 to 9 of 9
  1. #1
    pjsc823's Avatar
    Join Date
    May 2008
    Location
    Biloxi miss
    Posts
    135

    2004 msx150 not turning up

    As soon as you put the lanyard on the light flashes check engine Runs fine up to 6500 rpm then stays there. Would go to dealer to get codes but not one near or within 250 miles that can pull them. Has new map sensors and compression is good 140 on both. Any ideas


  2. #2

    Join Date
    Apr 2010
    Location
    Stamford CT
    Posts
    129
    What you describe, is it on the trailer or in the water? These skis are noted for revving wildly out of the water and the light could be due to the lack of cooling water flow. From the great minds on this forum and from my on ski, starting it in reverse is a good idea when the ski is out of water. It will limit rpms to 3400 give or take a few.

  3. #3
    jackofalltrades's Avatar
    Join Date
    Aug 2010
    Location
    Cabot Arkansas
    Posts
    592
    I am not well versed on the MSX150. Take a look here > http://polarispwcknowledge.shorturl.com/ < for info pertaining to your ski if you have not previously done so. On the Weber ECU I dont know if there is a way to read the codes easily like on other Polaris skis. Someone else will chime in I am sure. Cheers.

  4. #4
    pjsc823's Avatar
    Join Date
    May 2008
    Location
    Biloxi miss
    Posts
    135
    It's in the water and idles fine at 1500

  5. #5
    pjsc823's Avatar
    Join Date
    May 2008
    Location
    Biloxi miss
    Posts
    135
    No one close has software to pull codes could I take ecu out and ship to someone to to check codes

  6. #6
    pjsc823's Avatar
    Join Date
    May 2008
    Location
    Biloxi miss
    Posts
    135
    Anyone

  7. #7
    Kosh's Avatar
    Join Date
    Sep 2007
    Location
    Australia
    Posts
    1,483
    +1
    83
    The craft runs ok in the water but is limited to 6500 rpm with the light flashing all the time?
    It revs it's little heart out on the trailer(normal, put it in reverse,sometimes it will settle)

  8. #8
    pjsc823's Avatar
    Join Date
    May 2008
    Location
    Biloxi miss
    Posts
    135
    Idles fine out of water just won't turn up all the way in water only turns 6500 and engine light never stops blinking

  9. #9
    Matrix 4-Tec spannerspencer's Avatar
    Join Date
    Nov 2010
    Location
    south west England
    Posts
    1,143
    +1
    38
    ive only got limited experience on the electronic brains on these turbo msx's,

    does your waste gate arm on the turbo move freely? if you search in tech tips and info you should find some PDF files, of most of the sensors (so you can check to see if you have a duff sensor.)

    i had a limit of 6K. and i couldnt get it to rev.


    if all else send you ecu for test at www.precisionsports.ca as Martin can read your ecu (along with your sympoms) and 9 times out of 10 tell you exact region of fault

    (martin explained how my ecu was locked in safe mode - and that he thought it was due to the intake map sensors - he believed the ecu eventually locked in safe mode due to the sensors)

    my map sensors tested perfect. but it turned out they are very sensitive. after he unlocked the ecu it ran full revs, then limited to 6k ish. after i removed map sensors (which looked clean) and cleaned it ran full revs for a short time untill same limited revs occured.

    the route cause for all this was a worn turbo misting oil into the intake, so i needed a new turbo!


    hope this helps in some way. i tryed to make a OBD code reader but you cant access codes in the bosch ecu that uses electronic throttle

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 msx150 not reving past 3400 rpm
    By stevenmoua in forum MSX/Matrix
    Replies: 39
    Last Post: 07-28-2016, 06:51 PM
  2. 2004 msx150 not quite there yet
    By newt in forum Polaris Open Discussion
    Replies: 6
    Last Post: 08-25-2015, 10:53 AM
  3. MSX150 when reved up will not return to idle.
    By GLS in forum Polaris PWC Performance
    Replies: 2
    Last Post: 08-20-2013, 10:30 PM
  4. 98 slxh does not turn over - sat up for a couple of years
    By tryintolearn in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-02-2012, 10:33 PM
  5. 2004 rxp not hooking up
    By martin_7238 in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-20-2010, 04:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •