Results 1 to 3 of 3
  1. #1

    2002 genesis i, does motor need to run for fwd/ rev to work?

    I've read here that older skis need to have the engine running for trim to work. I'm wondering if the motor needs to be running for the foward / reverse mechanism to work also.


  2. #2
    retro's Avatar
    Join Date
    Jun 2009
    Location
    Annapolis
    Posts
    492
    +1
    2
    If the motor is running it should work. When the motor is not running if you depress and hold down the bilge button while pushing the forward/reverse it should also work.

  3. #3
    Thanks retro, I'll try that

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Does engine need to be running when adding anti-freeze?
    By xray328 in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 09-20-2011, 01:18 PM
  2. does pump need to come off for rideplate removal?
    By coolshirt in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-20-2011, 01:34 AM
  3. Can I Paint The Bottom Of My Jet Ski Or Does It Need To Be Gel Coat???
    By 1998PRO785HO in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 11-04-2010, 06:30 PM
  4. does this need to be glassed???
    By killcraft in forum Polaris Open Discussion
    Replies: 9
    Last Post: 03-08-2010, 04:12 PM
  5. Why does engine need to run during flushing?
    By zone 5 in forum 4-Tec Performance
    Replies: 15
    Last Post: 11-15-2008, 07:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •