Page 1 of 7 1 2 3 ... LastLast
Results 1 to 10 of 69

Thread: what the F??/

  1. #1
    Jerry, Jerry, Jerry jerryspringer's Avatar
    Join Date
    Oct 2008
    Posts
    248
    +1
    8

    what the F??/

    hi guys ,

    frustration really kicking in..

    2011 rxpx - owned since new and added the followings mods at 20 hrs

    8650 ecu reflash
    les cooke b kit
    retainers
    4 inch air
    thermostat




    i cant get speed.. ! regardless of conditions ,weather ,fuel ,cold or warm somehings not right - no joy! best run is 74 mph.(GPS)

    i started with 14/18 skat , repitched to 8550 rpm - got smoked by mates rxp with xcharger/ecu reflash and air
    tried again and had my stock prop repitched - still no joy

    now i ve bought a solas 15/22 r - take off is slower and revving only to 7900 rpm - like i dont have enough power to turm prop..

    my brother has a stock rxpx 2011 - and im only marginally quicker running my repitched stock prop (thats the fastest setup ive had)

    i ve checked boost - no leaks, pulled intercooler and cleaned (just incase) - boost is at approx 14 psi

    big $$ spent with no go to match =

    Arent these 14 psi chargers supposed to kick hard--?? am i expecting to much??
    any clues???


  2. #2
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Are you running the stock grate? Put on a R&D grate.

  3. #3
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Stock injectors?
    What are your afrs at WOT?

  4. #4
    boostedpgt's Avatar
    Join Date
    Jun 2011
    Location
    Jacksonville, Florida, United States
    Posts
    240
    hows the wear ring? that makes a HUGE difference. and are you fat? i am 260ish and that slows mine down a ton!

  5. #5
    Stockrxp's Avatar
    Join Date
    Aug 2010
    Location
    texas
    Posts
    1,009
    +1
    1
    Quote Originally Posted by boostedpgt View Post
    hows the wear ring? that makes a HUGE difference. and are you fat? i am 260ish and that slows mine down a ton!

  6. #6
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    It's your fuel pump possibly. Mine did the same thing and I chased my ass for months. There is not enough fuel pressure to get the RPM's up. I added a Walbro and no more issues. I could only rev to 7920. Changed the pump, revving 8600 now. I chased timing, cam, injectors, prop, shoe, grate, plugs, gaskets, drive shaft, charger, oil, etc..... I chased everything except the fuel pump. Often the simplest of answers are the most likely of culprits. Good Luck.

    The way I figured it out was that with the RRFPR, I could crank the regulator wide open and it would not go past 64psi on idle no matter how high I put it. So with the base pressure at 59, adding 13-14lbs of boost, I was over extending the power of the OEM pump. New one in, BINGO! This is where I would start. The pumps are $85.00 and a good investment especially for a B kit.

  7. #7
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Something is definitely wrong bro! Did you have to add or take pitch from the Skat prop to get 8550? I'm asking because my setup is similar and I can turn the 15/19 +1mm to 8600 and about 76mph on the GPS. When I had the 15/22 I could turn that to 8500. It seems to me like you are missing about 600rpm. I'd start with plugs, checking oil level, wear ring, etc.

    You should blow away a stock x ski.

    Msrxp might be on to something there.... But you are running stock injectors and reg if I'm correct?

  8. #8
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by monaroman76 View Post
    Something is definitely wrong bro! Did you have to add or take pitch from the Skat prop to get 8550? I'm asking because my setup is similar and I can turn the 15/19 +1mm to 8600 and about 76mph on the GPS. When I had the 15/22 I could turn that to 8500. It seems to me like you are missing about 600rpm. I'd start with plugs, checking oil level, wear ring, etc.

    You should blow away a stock x ski.

    Msrxp might be on to something there.... But you are running stock injectors and reg if I'm correct?
    Stock injectors with a B kit? Get a set of actual 48's rated for high pressure. They won't hold up to that much pressure and will fail or not let the required amount of fuel out which will limit the engine for safety. It's the same way that you cannot take a set of stock x 42's and replace them in another modified ski needing 42's. The pressure is too high and usually causes problems in my experiences. I would get a set of LUCAS injectors from suck my wake. I have been using them for over a year and I am really pleased. I would also change the pump while you are there. It wouldn't hurt. You are already a good chunk of $$ in it, what is another $300, right? It definitely sounds like a fueling issue. Maybe I am wrong, just seems to fit with what problems I experienced....

  9. #9
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Quote Originally Posted by MSRXP View Post
    Stock injectors with a B kit? Get a set of actual 48's. They won't hold up to that much pressure. It's the same way that you cannot take a set of stock x 42's and replace them in another modified ski needing 42's. The pressure is too high and usually causes problems in my experiences. I would get a set of LUCAS injectors from suck my wake. I have been using them for over a year and I am really pleased. I would also change the pump while you are there. It wouldn't hurt. You are already a good chunk of $$ in it, what is another $300, right?
    From memory, he has a Les Cooke reflash and Les has assured him his set up will be safe with the stock injectors. Correct me if I am wrong OP!

  10. #10
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by monaroman76 View Post
    From memory, he has a Les Cooke reflash and Les has assured him his set up will be safe with the stock injectors. Correct me if I am wrong OP!
    It is not uncommon for an OEM injector to fail. Yes, they will work but have a tendency to fail. It is not unheard of for people to run OEM injectors. If I remember correctly, 9SecZ06 ran stock injectors in his OEM '11 t-x and was ok for awhile though. I was stating in my experiences ONLY, that I have seen injectors begin to fail as they are not rated for that high of a pressure when boosting big like that. Les knows what he is doing, NO QUESTION!. I am speaking from my experiences, not anyone else nor am I waging war on Les.... Period. Just stating my previous issues.... Nothing more, nothing less....

    Oh, is he running a regulator (RRFPR) with that 'B' Kit? Should be for safety IMO! Especially if it tends to run lean without it.....

Page 1 of 7 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. This **** catch can, what the fittings called?
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 53
    Last Post: 04-23-2006, 10:09 AM
  2. What the best air intake system for an RXP as Spring 2006?
    By Jarrett in forum 4-Tec Performance
    Replies: 44
    Last Post: 04-15-2006, 09:33 AM
  3. What the.....???????? HELP!!!!
    By Totallyblown in forum 4-Tec Performance
    Replies: 50
    Last Post: 04-02-2006, 02:27 PM
  4. WHAT THE!
    By meeper in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 02-03-2006, 04:08 PM
  5. Someone tell me what the hell this is
    By peteshauling in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 08-28-2005, 10:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •