Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 57
  1. #1

    Join Date
    Jul 2011
    Location
    Illinois
    Posts
    103
    +1
    2

    '97 XP electrical problem

    I recently purchased a 97 Seadoo XP and was told by the previous owner that it had an electrical issue that was most likely a faulty DESS post. When you place the DESS key on the post the ski makes no beeps but the VTS gauge comes to life as you can see in the picture below. I also pulled out the fuses and did not see any issues. ( The picture below is of the 5 amp fuse) The previous owner also showed me that the engine would turn over by jumping two wires together but not sure what he was doing to get this to happen. I am afraid I need a new MPEM but wanted to get others opinions before I make that purchase.

    Thanks,
    Chris





  2. #2
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    time for an MPEM....contact "the wayniac" or "mongoose2" they will have a good used ones for you.

  3. #3

    Join Date
    Jul 2011
    Location
    Illinois
    Posts
    103
    +1
    2
    I was afraid this was the response I would get. But why is the fuse not blown?

  4. #4
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Quote Originally Posted by chrisshep83 View Post
    I was afraid this was the response I would get. But why is the fuse not blown?
    because its already fried somewhere before the fuse. mine did the same thing when it blew. dont worry mpems for this model are cheap anymore...maybe $150 bucks for a good used one

    I bet the PO tried to jump start it from a running car and blew the MPEM. the one thing that your never supposed to do...he must have done.

  5. #5

    Join Date
    Jul 2011
    Location
    Illinois
    Posts
    103
    +1
    2
    Note to self...never jump a seadoo. I was also working on my GTX this weekend and found a oyster jammed in my intake grate, I rode it twice since this happened would of cost a lot more than a new MPEM.




  6. #6
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    where are you riding in Illinois and finding oysters? lol

  7. #7

    Join Date
    Jul 2011
    Location
    Illinois
    Posts
    103
    +1
    2
    Had the ski down in South Carolina. It was probably 80% of the way thru the grate...

  8. #8

    Join Date
    Jul 2011
    Location
    Illinois
    Posts
    103
    +1
    2
    I just received a used MPEM, anything I need to keep in mind when I install this one? I just want to make sure I don't mess anything up.

  9. #9
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    nope just plug it in. make sure that you do it wire for wire instead of ripping it out all at once. i cant remember if the 97 had the gray box or the upgraded mpem.

  10. #10

    Join Date
    Jul 2011
    Location
    Illinois
    Posts
    103
    +1
    2
    Bad news.... I replaced the MPEM and still had the same problem... Plugged the DESS key in and my VTS gauge raised but nothing else beeped or turned on. So I then replaced the DESS post with a replacement from Seadoo... Still have same problem. So what do I try next??

Page 1 of 6 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 xp electrical problem
    By XP537 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-27-2010, 09:53 AM
  2. 97 XP 800 problem during running.
    By dre23 in forum 2-Stroke Performance
    Replies: 7
    Last Post: 03-04-2010, 09:49 PM
  3. 97 xp vts problem
    By punchtech in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-21-2008, 07:15 AM
  4. 97 xp vts problem
    By punchtech in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-20-2008, 11:28 AM
  5. 97 xp electrical
    By Stoffa17 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-21-2007, 12:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •