Results 1 to 10 of 10
  1. #1
    onelegman's Avatar
    Join Date
    Feb 2012
    Location
    arizona
    Posts
    9

    Rxp-x water in oil and burning oil help

    hello my ski sat out on my dock this winter so when i got it started it was running like crap I thought i wood get luck on old gas so i put some new gas in it and i tried running it wodent go above 3500rpm then as thing codent get better she start burning a lot of oil.. after i got it out i drained the oil and it was milky as all can be the oil filter has little bits of matel all in it. I think i know whats going but I wood like someone's else opinionon uthere than my owen. THANKS

    MODS
    riva open loop cooling
    riva 8750 ecu
    and all the goody that com with those


  2. #2
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Do you think it froze while sitting outside and you cracked the block?

  3. #3
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    There it is in your mods list (Riva Open Loop). Machine wasn't winterized properly and the engine froze busting the block, likely a water jacket split into one of the combustion cylinders. Check the compression to determine there is a problem there, if so pull the head to inspect the cylinders. Sorry to hear that!

  4. #4
    I assume it was all sealed up and covered? If so the milky oil could be condensation.

    I would pressure test the cooling system and if thats all good Have a look at your bore. Fresh water or salt water? Do you fog the ski?

    Quote Originally Posted by onelegman View Post
    hello my ski sat out on my dock this winter so when i got it started it was running like crap I thought i wood get luck on old gas so i put some new gas in it and i tried running it wodent go above 3500rpm then as thing codent get better she start burning a lot of oil.. after i got it out i drained the oil and it was milky as all can be the oil filter has little bits of matel all in it. I think i know whats going but I wood like someone's else opinionon uthere than my owen. THANKS

    MODS
    riva open loop cooling
    riva 8750 ecu
    and all the goody that com with those

  5. #5
    primorxp's Avatar
    Join Date
    Jul 2009
    Location
    Saint Louis, Missouri, United States
    Posts
    415
    +1
    11
    Do a compression check drain all the oil and replace it might take a couple of times to get it all out and change plugs. A friend of mine left some of the milky oil in ski and did not change it again and it was milky after he ran it so he had it rebuilt and their was nothing wrong. A bit costly for a few quarts of oil. IMO

  6. #6
    onelegman's Avatar
    Join Date
    Feb 2012
    Location
    arizona
    Posts
    9
    well iv ben going to school in Arizona and my ski was in Texas on lake Travis. the answers i got was it fourze only a couple of time not to cold but so I have no idea if it got cool enough to do anything If the block crack I cant see any dame on the out side the internal is a different story the ski has about 140h on is so its a worn motor I had a problem with water in the oil and obviously the guy didn't fix it I think is my pto housing the bad seal and rely bad head gasket and piston rings

  7. #7
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    Go get you a cheap compression gauge, check the compression on all three. If all is good there get you some hose fittings and check the cooling system for a pressure drop. 3500 RPMs sounds like a dropped cylinder to me. Hopefully I am wrong!

  8. #8
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    I have seen a oil cooler or two go bad. Only thing is once the engine is running it pushes oil out not water into the engine. Water traps in the engine with the RIVA open loop kit.

  9. #9
    onelegman's Avatar
    Join Date
    Feb 2012
    Location
    arizona
    Posts
    9
    grate thank four yall help. well if it is that I think is a good excuse to put some cp piston in and pourt the head

  10. #10
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    Quote Originally Posted by onelegman View Post
    grate thank four yall help. well if it is that I think is a good excuse to put some cp piston in and pourt the head
    Yea, after you locate a good block to rebuild. Depending on your budget you may decide to go with an SBT engine or locate a good used one. Damn, did I just suggest an SBT? What the hell was I thinking.....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 08 ultra 250x WATER IN OIL!! Help!
    By chisel in forum Kawasaki How To & FAQs
    Replies: 38
    Last Post: 11-12-2015, 09:09 AM
  2. 04 fx HO water in oil!!! Help
    By stang4u2nv in forum Yamaha PWC Performance (4-stroke)
    Replies: 13
    Last Post: 10-04-2010, 02:32 PM
  3. 2004 fx HO water in oil!!!! Help
    By stang4u2nv in forum Yamaha Open Discussion
    Replies: 8
    Last Post: 10-03-2010, 07:53 PM
  4. Help! GIO and now water in oil!!!
    By fairlanex in forum Kawasaki PWC Performance (4-stroke)
    Replies: 13
    Last Post: 05-23-2008, 09:42 AM
  5. 06 rxp water in cylinders and oil help please
    By blue5speed in forum 4-Tec Performance
    Replies: 7
    Last Post: 01-04-2008, 09:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •