Results 1 to 10 of 10
  1. #1
    Mothman's Avatar
    Join Date
    May 2011
    Location
    West Texas
    Posts
    2,999
    +1
    1,479

    Head cover oil leak

    Ok. My build is complete and she runs. Check check. I noticed a large amount of oil spurting from between the head cover and head. I could physically see the gap and move the rubber gasket up and down by hand. I checked the 8 cover torx screws, and they were properly tightened. I've taken the cover on/off and tightened according to the manual, to no avail.
    Also, the keeper sitting next to the rocker shaft on top of cylinder three seems to be a bit high. Is this keeper supposed to be flush with the head? The cover itself has a large dent in the rubber where this keeper is held down. Here are some pictures. Pleeeeease help!

    Click image for larger version. 

Name:	GOPR0331.jpg 
Views:	36 
Size:	66.8 KB 
ID:	265507Click image for larger version. 

Name:	GOPR0328.jpg 
Views:	37 
Size:	75.1 KB 
ID:	265506Click image for larger version. 

Name:	GOPR0332.jpg 
Views:	32 
Size:	46.5 KB 
ID:	265508


  2. #2
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    I remember reading when running head studs there is one in the front that needs to be ground down a littlle so the valve cover will seal. Cant remember if it is left or right.

  3. #3
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    I grind down the spot inside the valve cover not the stud.

  4. #4
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by jp1300r View Post
    I grind down the spot inside the valve cover not the stud.
    Yup, it usually hits on the 2 front bolts

  5. #5
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Oh, the keeper looks ok. Here is a pic to compare.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	P2050014.jpg 
Views:	81 
Size:	145.4 KB 
ID:	265509  

  6. #6
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Well I was kinda close. lol

  7. #7
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Quote Originally Posted by troyheb View Post
    Well I was kinda close. lol
    On Todd's turbo motor, we did have to cut his studs

  8. #8
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Quote Originally Posted by WFO View Post
    Yup, it usually hits on the 2 front bolts
    It was just the front right bolt for me. A quick bodge job on the underside of the valve cover and she was good to go.

  9. #9
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    +1, Should be some marks inside the valve cover now from trying to put the valve cover on a couple times.

  10. #10
    Mothman's Avatar
    Join Date
    May 2011
    Location
    West Texas
    Posts
    2,999
    +1
    1,479
    I didn't notice marks on the cover. I'll check more thoroughly tomorrow! Thank you for the help. Again, this forum rocks...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SPX 787 Cyl Head Cover Leak?
    By trxxx250r in forum 2-Stroke Performance
    Replies: 7
    Last Post: 05-17-2016, 09:38 PM
  2. Valve cover gasket leaking oil
    By EGGonz in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 09-15-2007, 10:04 AM
  3. Oil leak
    By mjet in forum 4-Tec Performance
    Replies: 0
    Last Post: 10-02-2006, 11:08 PM
  4. Oil leaking near SC
    By Stretch in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-14-2006, 07:37 PM
  5. I might have a oil leak in the RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-02-2005, 12:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •