Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    RXP Stays on after I remove the key????

    When for a nice Blast today and all was good. Got home flushed ski had a bit of a down pore so engine got a bit wet(not much at all). Waited for rain to stop gave it a quick fog... Pulled the key to stop it and it kept running?? Stopped it with the start/stop button OK.........BUT ignition is still on without key in?? the only way to cut ignition power is to disconnect the Battery!

    I'd say something got wet but what??????? I pulled the plugs off all the sensors, coils, injectors and ECU and blasted with air gun to make sure they were dry no help!! Tried Learner key.....No Help! Checked all the earthing, It all seems good!





  2. #2
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Sounds like your DESS post is stuffed. There is two reed switches in the post that can fail. I recently worked on a buddies ski who was having the opposite problem (no power at all). One of the reed switches in the post was sticking closed.

  3. #3
    Cheers, I'll pull the post and have a look.

  4. #4
    Cheers Matthew you've earned your 45deg fitting. Both the rubber seals for the two DESS plugs had split and they had water in them! Blew out the the water and ready to race again!!

    Never expected the ski to stay on as a result of that though?? O Well live and learn!

  5. #5
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Quote Originally Posted by WangaRXP View Post
    Cheers Matthew you've earned your 45deg fitting. Both the rubber seals for the two DESS plugs had split and they had water in them! Blew out the the water and ready to race again!!

    Never expected the ski to stay on as a result of that though?? O Well live and learn!
    Awesome

    All that putting the lanyard on the post does is complete the circuit to the main relay to power everything up. I guess if you had water in the plugs coming from the DESS post it could have created a short and been bypassing the post. If that was your problem and the post is fine, that's great news, saves you from having to buy another post.

  6. #6
    A smart admits!A wicked excuses!An idiot insists! mitsakosgt's Avatar
    Join Date
    Jun 2008
    Location
    GREECE ATHENS , NAXOS
    Posts
    2,691
    +1
    40
    Quote Originally Posted by monaroman76 View Post
    Sounds like your DESS post is stuffed. There is two reed switches in the post that can fail. I recently worked on a buddies ski who was having the opposite problem (no power at all). One of the reed switches in the post was sticking closed.
    +1,I had the exact same problem on a customers ski.I change the dess post and the ski worked fine!

  7. #7
    Greenhulk Grasshopah (DRC) HallPass's Avatar
    Join Date
    Jun 2007
    Location
    Kansas
    Posts
    5,587
    +1
    2
    Where do you buy a replacement dess post

  8. #8
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Online store!

  9. #9
    A smart admits!A wicked excuses!An idiot insists! mitsakosgt's Avatar
    Join Date
    Jun 2008
    Location
    GREECE ATHENS , NAXOS
    Posts
    2,691
    +1
    40
    Quote Originally Posted by monaroman76 View Post
    Online store!
    +1

  10. #10
    Greenhulk Grasshopah (DRC) HallPass's Avatar
    Join Date
    Jun 2007
    Location
    Kansas
    Posts
    5,587
    +1
    2
    Yeah but which part do I order part #?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. HELP.......RXP X260 2013 ... Power stays on when lanyard is removed
    By Hayabusa2RXP in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 08-28-2016, 06:26 PM
  2. Help rxp stays on when key is not in please help
    By vicario62590 in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-05-2014, 06:37 AM
  3. Replies: 3
    Last Post: 06-18-2012, 03:52 AM
  4. Is it possible to replace Stator on FX140 without removing the engine?
    By gregpwc in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 04-19-2012, 04:23 PM
  5. Getting RXP back tomorrow after down time in the shop.
    By Jrsrxp in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-14-2005, 09:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •