Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    tick.. tick.. RXPteamtimebomb's Avatar
    Join Date
    Jan 2007
    Location
    Maryland
    Posts
    726
    +1
    13

    RXP jet pump bearings.. Question

    My bearings were shot.. Really bad and I'm glad it didn't cause any damage other than just the bearings.. When they were shot, the prop would spin at least a full rotation or so when spun by hand.. My question is with new bearings and rebuild the pump bearings feel a lot tighter and the prop will not spin around when spun by hand.. It feels real smooth when turning it by hand though, I'm sure a 200+ hp motor won't have a problem spinning the prop, but is this normal? I dont remember from when I had the pump rebuilt last, thanks


  2. #2
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    My pump has never been rebuilt that i know of, I have an 04 rxp but my pump has a 2006 on it, so i'm thinking the original owners might have had to replace the pump. That being said I don't have a clue how many actual hours are on my pump, how often should the pump be rebuilt?

  3. #3
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    Thats normal for the prop to spin about a 1/2 to 3/4 turn when spun by hand. The seals are fresh & tight.

  4. #4
    tick.. tick.. RXPteamtimebomb's Avatar
    Join Date
    Jan 2007
    Location
    Maryland
    Posts
    726
    +1
    13
    Is it normal with no spin by hand at all? Mine stops as soon as I let go, tight.. Is that normal?

  5. #5
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    they really only go together one way so I'm sure its fine, the grease in the new bearing just needs to be warmed up. ditch the grease in the pump cone and rock some of the royal purple marine grade gear lube instead....

    your not that far from me if your bored one day i can give you some and check the pump out, i just got a bunch of the gear lube

  6. #6
    wakejumper48's Avatar
    Join Date
    Sep 2010
    Location
    Florida
    Posts
    248
    +1
    3
    Quote Originally Posted by meeper View Post
    they really only go together one way so I'm sure its fine, the grease in the new bearing just needs to be warmed up. ditch the grease in the pump cone and rock some of the royal purple marine grade gear lube instead....

    your not that far from me if your bored one day i can give you some and check the pump out, i just got a bunch of the gear lube
    don't mean to hack thread but u would recommend switching to oil filled cone other than grease filled? makes since but how much oil u put in the cone fill it up?
    thxs just wondering

  7. #7
    Electronics Guru Alpheus's Avatar
    Join Date
    Aug 2010
    Location
    Lake Anna Va
    Posts
    520
    +1
    1
    Quote Originally Posted by wakejumper48 View Post
    don't mean to hack thread but u would recommend switching to oil filled cone other than grease filled? makes since but how much oil u put in the cone fill it up?
    thxs just wondering
    2.5 ounces...

  8. #8
    tick.. tick.. RXPteamtimebomb's Avatar
    Join Date
    Jan 2007
    Location
    Maryland
    Posts
    726
    +1
    13
    There's another thread all about this.. Search

  9. #9
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    I run 10W40 Mobil 1 synthetic eng oil in mine

  10. #10
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by psycho rxp View Post
    I run 10W40 Mobil 1 synthetic eng oil in mine

    Some closed course racers use transmission fluid also

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP bilge pump install question
    By sea-one in forum Open Discussion
    Replies: 0
    Last Post: 11-18-2009, 07:14 PM
  2. Jet pump assembly question
    By cubsfan2516 in forum Polaris Open Discussion
    Replies: 15
    Last Post: 05-13-2009, 03:09 PM
  3. Anyone have a pic of RXP jet pump support ?
    By DaveC in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 03-16-2008, 05:27 PM
  4. Pump bearing question
    By porksword in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 02-05-2007, 05:49 PM
  5. Jet pump bearing grease on rxp
    By dre23 in forum 4-Tec Performance
    Replies: 12
    Last Post: 12-11-2006, 11:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •