Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 44
  1. #1

    Join Date
    Sep 2011
    Location
    Ottawa, Ontario
    Posts
    79
    +1
    1

    95 Polaris SL(T?)750 with a fuji 780 engine.

    Hello all.
    I purchased this machine in sept. Took it out for a run (before the water got to cold!!) Ran like a dream.
    Few things I need to fix before this coming summer.
    1. The guy told me the MFD didn’t work. Yes he was correct it sure doesn’t work…all the wires have been cut! I will try one of the MFD fixes I have read in this forum and see if I can get it working again. If this doesn’t work, I don’t feel like spending hundreds of dollars installing a used MFD on this machine. It’s the round kind and I only really need a fuel gauge and temp gauge.
    2. Any ideas on what models of fuel and temp gauge will work?
    3. I still have to see if the sending units are serviceable or not(I did notice the temp sensor and the fuel sensor wires were cut…extremely close to the units so they may to be replaced regardless)
    4. The electric trim. It works, I tested the motor, trims up and down just fine, and it’s the switch that is not working. It will trim down, but not up. I don’t want to spend large amounts of dollars replacing it with a used switch. So what I would like to do is install a simple 3 pole toggle switch…centre off, up- trim up, down- trim down. Like I said simple. Any thing special I need to know about this type of switch for a PWC? I will look for a good marine grade switch for sure.
    Finally (well not really but for now it is) is there anyone in the Kingston, Ontarioarea that knows of a service centre that can/will tune a Fuji 780 engine? I have to rebuild the carbs,the fuel lines in the fuel tank had rotted, and I found a lot of brown gunk in the water/fuel separator and fuel filter from these lines. I can do the rebuild myself but it’s the tuning afterwards that I will be unable to accomplish.
    While i am doing that i would also like to replace the flame arrestor with a good set of used Vortex so it will need to be tuned.

    Any help with the above would be greatly appreciated

    Thanks


  2. #2
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30
    Welcome to the Hulk!

    What are the MFD's problems?

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    Welcome to the hulk kaiser.

    How about posting a pic of your ski you have? I have a funny feeling you may have a 1993 SL 750.

    I think you're mistaken about the cost of some of the parts.

    The round MFDs are not that sought after, so the prices are usually lower for those. Can prob get a used one around $100 USD.

    The MFD doesn't have a temp gauge. It just has a warning indicator when an overheat occurs. So installing a temp gauge will be completely custom on your part.

    As for the fuel gauge, the Polaris gauges use 0 --240 ohms to read fuel level. I would think you'd have to find a fuel gauge that works using those readings.

    OR, just get an MFD.

    The start/stop switch with trim button are cheap. You can prob get a used one for less than $30. I had a couple i sold for less than that.

    Don't be afraid to search the classifieds on here or contact John Zigler for good used parts as well.

    I highly doubt you'll find anyone willing to service your ski. Maybe an independant service facility, but definately not a Polaris dealer. I honestly would suggest you taking the time to tune it yourself. It'll save you $$$, it will give you a rewarding feeling, and give you the experience you'll need to KEEP your ski maintained for years to come.

    If you keep it mostly stock, you'll be able to follow the service manual or be pretty darn close to stock settings.

    But lets see what you have first...

  4. #4
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Welcome to the Hulk!

    Like Xlint said, a lot of us have excess parts laying around and would be willing to get them to you for a more than reasonable cost, but we want to make sure we send you the right stuff, so up with the pics........

    I have a used MFD that displays great and works fine, except for the buttons that I would let go super cheap......

    PICS!


    http://www.ebay.com/itm/94-95-Polari...#ht_500wt_1156

  5. #5

    Join Date
    Sep 2011
    Location
    Ottawa, Ontario
    Posts
    79
    +1
    1
    Thanks folks.
    I will get the pics up soon.
    I will verify the engine and hull
    As for the MFD, i have no idea what was wrong with it. But what i do know is that all the wires have been cut short! On the sensors and on the MFD itself. I will check the fuse in the electrical box, then i will clean the MFD, and check that, along with checking the sensors.
    I guess i will have to do the tuning myself...FORTUNATELY this forum is chalked full of helpful hints and detailed explainations on how to do this stuff...so i will read and do.

  6. #6

  7. #7

    Join Date
    Sep 2011
    Location
    Ottawa, Ontario
    Posts
    79
    +1
    1
    Click image for larger version. 

Name:	FuelSensorJpeg.jpg 
Views:	60 
Size:	34.7 KB 
ID:	266086

    Just figuring out how to send a pic.
    Thats the fuel sensor!!...I have no idea where the rest of it is...it is not in the fuel tank!!! I looked
    However..i think its a mute point at this time..wait till you see the electrical box...

  8. #8

    Join Date
    Sep 2011
    Location
    Ottawa, Ontario
    Posts
    79
    +1
    1
    Click image for larger version. 

Name:	Elecbox1.jpg 
Views:	87 
Size:	89.7 KB 
ID:	266089
    Nasty!
    So here is what you cant see.
    I took the cover off and found a black wire had been pinched between the cover halves. According to the shop manual i just cut the black wire to my killswitch! Found a yellow wire that was disconnected from the board, no idea where it goes. Found another wire that was crimped off.
    The MFD Fuse?? No where to be found...it is not on the bottom of the electrical box, nor can i find it in the rats nest in the top.

    I think i should pull this electrical box out, and clean it up...
    Question though.
    In no way shape or form am i mechanical inclined....i am even worse when it comes to electronics. I am the pull the wire off, clean it put it back on,move on to the next wire kinda guy.
    So
    Simplest method to removing this box completely so that i can clean it up would be????
    If i start pulling wires off the panel that is in there....this machine will never run again!!!!

    P.S..maybe this thread can be moved to the Polaris Projects Forum??
    Thanks for your help

    OH SNAP!! almost forgot.
    The hull plate says i have a 94 Polaris 750SL...i havent gotten to the engine plate yet...

  9. #9

    Join Date
    Sep 2011
    Location
    Ottawa, Ontario
    Posts
    79
    +1
    1
    Click image for larger version. 

Name:	MFD.jpg 
Views:	57 
Size:	72.5 KB 
ID:	266093

    Here is the MFD. Like i said previously i have to test it first...after seeing the condition of the electrical box and the fuel sensor...yea..i need to do some work before i start cutting it apart.

  10. #10

    Join Date
    Sep 2011
    Location
    Ottawa, Ontario
    Posts
    79
    +1
    1
    Click image for larger version. 

Name:	What is this.jpg 
Views:	103 
Size:	55.9 KB 
ID:	266095
    Could somebody tell me what this hose is for? Looking to the front of the machine, back of engine,lower right side. The hose(similar to a fuel line) is capped off. I cant find a reference to it anywhere in the Service Manual.

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95 Polaris SL 750, needle and seats. please help
    By 750slt in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-02-2009, 09:57 PM
  2. 95 Polaris SL 750, MULTI FUNCTION DISPLAY . please help
    By 750slt in forum Polaris Open Discussion
    Replies: 8
    Last Post: 05-30-2009, 10:56 PM
  3. 95 Polaris SL 750, removing starter. please help
    By 750slt in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-30-2009, 07:45 PM
  4. WTB: 94-95-96 Polaris SL Series Ski with a 750 engine
    By Feral in forum Polaris Classifieds
    Replies: 0
    Last Post: 06-16-2008, 10:09 PM
  5. 95 polaris sl 750 help
    By scottr2200 in forum Polaris Open Discussion
    Replies: 44
    Last Post: 07-09-2007, 08:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •