Results 1 to 3 of 3

Thread: Losing Speed ?

  1. #1

    Losing Speed ?

    how flush does the rideplate fit up against the pump on a gp1300r? Just wondering if it should be flush against the pump or sit up higher.


    THANKS DT


  2. #2
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    535
    Quote Originally Posted by DoomTrain View Post
    how flush does the rideplate fit up against the pump on a gp1300r? Just wondering if it should be flush against the pump or sit up higher.


    THANKS DT
    the plate should be about 50 thousands higher than the shoe. If it's lower than the shoe that will create drag and you will lose speed.

  3. #3
    What if its over an inch higher? The pump shoe and grate seat smooth together, and the stock ride plate sits up higher

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 21
    Last Post: 11-20-2012, 08:45 AM
  2. More Pump Issues??? (Losing speed again)
    By UNSANE in forum 4-Tec Performance
    Replies: 19
    Last Post: 10-21-2012, 11:30 AM
  3. Gpr1200 loses speed and power after extended wot
    By crittpen in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 06-27-2011, 10:20 PM
  4. Dealer overfilled Oil... Lose top speed?
    By Mikey in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-22-2009, 02:24 PM
  5. Add D Plate and lose top speed?
    By emcewin in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 09-17-2007, 05:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •