Page 1 of 64 1231151 ... LastLast
Results 1 to 10 of 634
  1. #1
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,709
    +1
    1,324

    X 45!!!!!!!!!!!!!!!!!

    I made it home with the X45. Trip took me from Milwaukee to Charlotte NC, to Ozark AL and back home. 2275 miles total. The ski is out in my driveway right now. I will post a few pics of what I have when it stops raining.

    I have been washing out the inside this morning. It was pretty greasy and messy inside. Im starting to wonder if this ski had been in salt water at some point in its life. The pump housing on the hull is so corroded inside that its going to have to be replaced. I hope the engine is ok internally. I was able to get to start and run after removing the jet pump.

    Turns out the bearings in the pump stator are seized up. Impeller and stator vanes look brand new. In fact it has a Nujet impeller, not the factory Polaris one.


    Click image for larger version. 

Name:	IMG_0569.jpg 
Views:	286 
Size:	124.5 KB 
ID:	266152Click image for larger version. 

Name:	IMG_0570.jpg 
Views:	232 
Size:	119.7 KB 
ID:	266153Click image for larger version. 

Name:	IMG_0571.jpg 
Views:	267 
Size:	128.2 KB 
ID:	266154Click image for larger version. 

Name:	IMG_0572.jpg 
Views:	246 
Size:	82.1 KB 
ID:	266155 .


    Still needs a little more cleaning inside.


  2. #2
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    918
    +1
    21
    Nice...looks like the outside is cleaning up well! Im jellous....

  3. #3
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,709
    +1
    1,324
    The outside is in pretty rough shape. Its getting a new paint job. Here is some of the damage I am going to fix. the top side isn't too dinged up, but there are a lot of paint chips and places where its coming off in the foot wells. New Turf will be in order as well. Do I go with the original black or go with blue? The only thing that would keep me from doing the blue is if it would have a tendency to fade like my red ones did on my SL 900. If its likely the blue would fade, I will just go with black again.

    Click image for larger version. 

Name:	IMG_0574.jpg 
Views:	155 
Size:	47.6 KB 
ID:	266156Click image for larger version. 

Name:	IMG_0575.jpg 
Views:	163 
Size:	54.0 KB 
ID:	266157Click image for larger version. 

Name:	IMG_0576.jpg 
Views:	156 
Size:	48.2 KB 
ID:	266158Click image for larger version. 

Name:	IMG_0577.jpg 
Views:	144 
Size:	46.4 KB 
ID:	266159

  4. #4
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,709
    +1
    1,324
    Got the Stator off and removed the impeller. There were no seals in it!!!! One of the bearings was locked up tight, that's why the motor wouldn't spin. When I picked up the impeller and turned it over, look what I found.

    Click image for larger version. 

Name:	IMG_0578.jpg 
Views:	284 
Size:	98.3 KB 
ID:	266160

  5. #5
    ujustlost's Avatar
    Join Date
    Oct 2006
    Location
    Howell Michigan
    Posts
    1,597
    +1
    6
    she's a beaut Clark !

  6. #6
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,709
    +1
    1,324
    Just looked at the bottom and I don't like what I see. Its going to get flipped over this weekend and I am going to repair the bottom as well. Lots of gouges and glass fiber showing. Time for some epoxy and glass mat, and a lot of sanding.....

  7. #7
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,813
    +1
    1,359
    Quote Originally Posted by ujustlost View Post
    she's a beaut Clark !


  8. #8
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,709
    +1
    1,324
    Pulled the heads to have a look. Not real bad but not real good either. Compression was a little low when I checked it. I had 120 PTO 120 Center and 125 MAG.

    Click image for larger version. 

Name:	IMG_0580.jpg 
Views:	211 
Size:	82.1 KB 
ID:	266165Click image for larger version. 

Name:	IMG_0579.jpg 
Views:	198 
Size:	135.6 KB 
ID:	266166Click image for larger version. 

Name:	IMG_0581.jpg 
Views:	195 
Size:	102.7 KB 
ID:	266167

    First pic is the PTO. Looks like its starting to get a hole in it. The third pic is the MAG piston. That one has some damage from debris on it. Looks like I might be doing a top end on it. Cylinder bores were clean with no rust though. Looks like the motor is coming out. Hopefully the crank is ok, but I'm not expecting it to be.

  9. #9
    ujustlost's Avatar
    Join Date
    Oct 2006
    Location
    Howell Michigan
    Posts
    1,597
    +1
    6
    Quote Originally Posted by beerdart View Post
    LOVE IT !!!!
    Quote Originally Posted by BryanP View Post
    Pulled the heads to have a look. Not real bad but not real good either. Compression was a little low when I checked it. I had 120 PTO120 Center and 125 MAG.







    Click image for larger version. 

Name:	IMG_0580.jpg 
Views:	211 
Size:	82.1 KB 
ID:	266165Click image for larger version. 

Name:	IMG_0579.jpg 
Views:	198 
Size:	135.6 KB 
ID:	266166Click image for larger version. 

Name:	IMG_0581.jpg 
Views:	195 
Size:	102.7 KB 
ID:	266167

    First pic is the PTO. Looks like its starting to get a hole in it. The third pic is the MAG piston. That one has some damage from debris on it. Looks like I might be doing a top end on it. Cylinder bores were clean with no rust though. Looks like the motor is coming out. Hopefully the crank is ok, but I'm not expecting it to be.
    When it comes to Polaris ski's I always set my expectations very low as far as condition of everything, this way I am never disappointed when its all FUBAR!

    Looks like a fun project, wish I lived closer to you to lend some help

  10. #10
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,709
    +1
    1,324
    I got the thing for 500 bucks........What should I expect?????

Page 1 of 64 1231151 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. The X (45) Files
    By CrazyA in forum Polaris PWC Performance
    Replies: 20
    Last Post: 04-10-2015, 08:55 AM
  2. Help with Fiberglass... 6oz cloth or 45+- Biaxial Mat
    By yellow4 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-24-2007, 04:18 AM
  3. X-45 No Spark - First Post
    By drummerman2028 in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 06-04-2007, 09:33 AM
  4. What Will $144.45 Get You On E-Bay? Shipped.
    By beerdart in forum Polaris Open Discussion
    Replies: 11
    Last Post: 03-29-2007, 10:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •