Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20

Thread: 05 RXT IC issue

  1. #1
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672

    05 RXT IC issue

    For shits and giggles I pulled my IC back out of the manifold and sure enough there's no rear O-Ring. There IS supposed to be one on the end that more or less slides on the TB inlet, right? If so it's made it's way up to the cylinder head.

    I've pulled the 7 or 8 stars from near the injectors but I'm sure there's another 4 or 5 where it's hard to reach


  2. #2
    rangermtb5's Avatar
    Join Date
    Apr 2008
    Location
    North Jersey
    Posts
    4,473
    +1
    58
    Quote Originally Posted by imp0ster View Post
    For shits and giggles I pulled my IC back out of the manifold and sure enough there's no rear O-Ring. There IS supposed to be one on the end that more or less slides on the TB inlet, right? If so it's made it's way up to the cylinder head.

    I've pulled the 7 or 8 stars from near the injectors but I'm sure there's another 4 or 5 where it's hard to reach
    here is a side-by-side of the '04 and '05, check out the o-rings http://www.greenhulk.net/forums/showthread.php?t=137067

  3. #3
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    yeah it's missing the large bottom one. Great. That means it's up near the head or stuck in a port.

  4. #4
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    Anyone know how to get the back bolts out? I can't get a socket on them.

  5. #5
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by imp0ster View Post
    Anyone know how to get the back bolts out? I can't get a socket on them.
    On the intake manifold?

  6. #6
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    yes. Or is it just the 7 or 8 bolts near the injectors and I just need to put some ass in it?

  7. #7
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Look in the manual but there is only 7 or 9.
    You have to pull the manifold away from the head and then list straight up. The manifold has feet that sit in a rubber groment.

  8. #8
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    I just found this. Looks like I just need to pry on it. Thanks

    http://www.rivaracing.com/instructions/rs12080_imuk.pdf

  9. #9
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Ya. Pry it back from head as there is a little tab by cylinder #1. Then lift straight up.

  10. #10

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 RXT Issues and questions
    By Miketran in forum 4-Tec Performance
    Replies: 7
    Last Post: 12-10-2013, 11:29 AM
  2. Replies: 15
    Last Post: 09-22-2010, 12:29 AM
  3. Driveshaft issue with 05 RXT
    By wickedpony2007 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 05-26-2010, 09:16 PM
  4. 05 RXT starting issues
    By Small Paul in forum 4-Tec Performance
    Replies: 18
    Last Post: 09-28-2009, 12:05 AM
  5. '05 RXT/GTX RR IC install question... O-ring?
    By 05Limited in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-03-2005, 09:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •