Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    Mar 2012
    Location
    Melbourne
    Posts
    6

    Question Sticky Steering - 2004 RXP

    Hey All,

    I recently bought a 2004 RXP in what I think is pretty great condition.. very very clean.. but it has one issue. The steering feels very 'sticky'. How smooth should the steering feel??

    When I turn the handlebars all the way left, or all the way right, they jam up enough that I need considerable force to turn them back.

    I've been told this could be a seized or partially seized (whatever that means) cable. I was quoted AUD $400 to have it replaced (parts + labour), which I think is unreasonable.

    I'm no expert, but I've inspected the steering mechanism as far as I can see without pulling anything apart. The cable looks to move quite smoothly in and out of the housing underneath the steering assembly, and is very well lubricated. Somehow I feel the steering is jamming up due to some other part of the mechanism, perhaps where the handle bars turn or the part that the cable is connected to?

    If anyone could shed any light on this, it would be much appreciated. I want to have it fixed, but I want to avoid paying $400, or worse, paying $400 when I should be paying much less.

    Thanks

    Aleks


  2. #2
    Hi mate
    I have an rxp that had a steering issue.
    It was the steering cable, these cables build up with salt. There are postings on how to free it up.
    I bought it from a forum member and changed it myself, wasn't that hard really.
    It was wayyyyyyy lower than $400 and easy....

  3. #3

    Join Date
    Mar 2012
    Location
    Melbourne
    Posts
    6
    Quote Originally Posted by pandan9 View Post
    Hi mate
    I have an rxp that had a steering issue.
    It was the steering cable, these cables build up with salt. There are postings on how to free it up.
    I bought it from a forum member and changed it myself, wasn't that hard really.
    It was wayyyyyyy lower than $400 and easy....
    Thanks mate!

    I've searched this forum for steering issues and haven't found any instructions on how to free it up.. As it's close to the end of summer, I don't want to have to mess about changing the cable.. I just wanna get a few rides out of it and worry about changing the cable over before next summer.

    If you could direct me to the right thread on here, that would be awesome.

    Cheers

  4. #4
    Here is a link that will help you:-

    This is a thread about lubricating the cable
    http://www.greenhulk.net/forums/show...0blaster%20psi

    If you want to remove the cable and change it, its easy.
    You don't need to remove the pump.
    A few bolts to remove the steering column and linkages on the pump side.

  5. #5

    Join Date
    Mar 2012
    Location
    Melbourne
    Posts
    6
    Hey mate.. I ended up getting the cable changed because I'd have no idea what I'm doing if I tried to free it up myself.. however, I got them to give me my old cable back. I've got it now and I'm gonna go through the steps detailed in the link to see how I go.. and hopefully that prepares me if my new cable seizes up in future.

    I took it out today, first time since i bought it, and it rocked. The acceleration on this thing is insane. Top speed wasn't too impressive though, 112km/h (69.6mph) with just myself on it.. on water like glass. Does that sound about right for a 2004 rxp?

  6. #6
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by aleksdanger View Post
    Top speed wasn't too impressive though, 112km/h (69.6mph) with just myself on it.. on water like glass. Does that sound about right for a 2004 rxp?
    If it's stock.... that's pretty much what it'll run.

  7. #7
    As bigdaddyrxp says, that's right for stock.
    What RPM did it run?
    How many hours on it?
    What State are you in?

  8. #8

    Join Date
    Mar 2012
    Location
    Melbourne
    Posts
    6
    I was told it had a stage two kit on it by the previous owner.. but i'm beginning to think it probably doesn't - oh well. Still got it at a good price i think. It ran at just under 8000rpm.. i'm not sure if it hit 8000 or more, i cant recall, but it was around there. Ski'd got 176 hours on it, engine rebuilt somewhere around 120hrs. I'm in Vic, I went to Nagambie today.. might hit up lake eppalock the next time i go.

  9. #9
    If its a stage 2, it will rev higher than 8000
    Can you check a few things?
    1) what colour are the injectors? (you may have to take off the plastic engine cover)
    2) is the air intake a round tube with an air filter?
    3) what does the water intake grate look like?

  10. #10

    Join Date
    Mar 2012
    Location
    Melbourne
    Posts
    6
    If you hadn't asked me to describe the intake grate, i probably never would have looked under my ski.. and lucky I did! I found the hull is quite damaged.. ffs.

    1) the injectors look black to me, with a big of orange where they connect to the engine... I've attached pics below.. hopefully you can make it out? If I'm looking at the wrong thing, whoops.

    2) I have no idea where to look for the air intake.. the whole engine compartment looks very crammed i can't really tell the difference between too many parts.

    3) the intake grate looks standard. It's black and just has two flat rods running from front to back.. unfortunately my camera battery died before i took a photo of that.

    Let me know what you think.. and what the hell do I do about the hull damage??

    This is the engine with the cover off.. sorry it's not too clear.


    Hull damage.. it's right in the centre of the hull. Looks like some idiot was banking this a little too hard on all sorts of crap.


    Thanks in advance!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts 2004 RXP steering cable
    By Turbo Retro in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 12-19-2013, 09:13 PM
  2. Upgrade options for my 2004 RXP Steering set-up
    By suisid2 in forum 4-Tec Performance
    Replies: 5
    Last Post: 10-04-2013, 08:12 PM
  3. Replies: 22
    Last Post: 06-19-2012, 08:28 PM
  4. 2004 RXP Steering cable help needed
    By NJMatt50 in forum 4-Tec Performance
    Replies: 0
    Last Post: 05-26-2009, 07:46 AM
  5. WTB; complete umi steering for 2004 rxp
    By macattack in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 07-23-2008, 11:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •