Results 1 to 8 of 8
  1. #1

    Problems taking oil tank apart

    tt
    Last edited by soulraver; 05-15-2012 at 03:42 AM.


  2. #2
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    What ski are you asking about? What your asking doesn't ring a bell to me with a Polaris ski design.

  3. #3
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Hi soulraver....... Please start with what kind of ski you have, and what the problem is and we will try to help....

  4. #4
    Matrix 4-Tec spannerspencer's Avatar
    Join Date
    Nov 2010
    Location
    south west England
    Posts
    1,143
    +1
    38
    he has to be talking about a MSX 110 OR 150

    ive also tryed todo this.

    i know Kosh did this with the aid of compressed air 15psi is too much (i tryed the same but accidently blew my oil tank up - still got a hole in my garage roof!) and warm up the aluminium section

    thy this thread link http://www.greenhulk.net/forums/show...light=oil+tank

    hope this answers your qu's?

  5. #5
    tt
    Last edited by soulraver; 05-15-2012 at 03:42 AM.

  6. #6
    Matrix 4-Tec spannerspencer's Avatar
    Join Date
    Nov 2010
    Location
    south west England
    Posts
    1,143
    +1
    38
    the main thing to check with the oil tank in pieces if the grooved for the o-seals, salt or raw water can rust them up causing as bad seal.

    remember a TINY leak is all you need to get the oil milky

    if you still get milky oil... it could be caused by a water pump seal.... i had this go on me and my oil went milky strait away.

  7. #7
    tt
    Last edited by soulraver; 05-15-2012 at 03:42 AM.

  8. #8
    Matrix 4-Tec spannerspencer's Avatar
    Join Date
    Nov 2010
    Location
    south west England
    Posts
    1,143
    +1
    38
    at this point i would check and ensure all your water joints are good on the turbo. are you loosing coolant?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil tank possible problem
    By Casey2552 in forum Yamaha Projects & Build Threads
    Replies: 0
    Last Post: 05-13-2014, 12:59 PM
  2. problem with oil tank/dipstick not going in.
    By Ricky Lopez in forum MSX/Matrix
    Replies: 1
    Last Post: 02-21-2011, 09:27 PM
  3. 96 spx anyone ever take off the oil tank to go premix
    By davidmcm in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-18-2010, 04:52 PM
  4. Oil Tank Leak
    By steach in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-15-2007, 05:04 PM
  5. Oil tank vent leaking.
    By FUBAR in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 09-03-2006, 06:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •