Results 1 to 10 of 10
  1. #1

    why does my ski lose fuel pressure when i turn it off?

    Hello friends, i use RRFPR, when i stop my engine i have 58 psi after 50 sec. pressure lost WHY? thanks ciao


  2. #2
    waseemyah's Avatar
    Join Date
    Aug 2011
    Location
    U.A.E Dubai
    Posts
    166
    well... I have the same thing and I really dont know why, it might be because the fuel pump is not working then there is no pressure to keep the psi at the same level!!! and after all i dont think this is a problem as long as the ski is operational.

  3. #3
    Hello I do not think the pump is because we measure the pressure regulator to the injectors??? mystery, I have injectors leaking pressure regulator that I have does not take pressure.

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Aftermarket regulators will all bleed down. The stock regulator has a check valve. Normal and will not affect anything.

  5. #5
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    +1 thats why the pump primes up when you start it..

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    When you turn your ski off the fuel pump stops working and the fuel pressure bleeds off. Perfectly normal!

  7. #7
    Quote Originally Posted by Green Hulk View Post
    When you turn your ski off the fuel pump stops working and the fuel pressure bleeds off. Perfectly normal!
    Thanks guys, This works well because it keeps other pressure? What do you think of Walbro pumps? hello all

  8. #8
    waseemyah's Avatar
    Join Date
    Aug 2011
    Location
    U.A.E Dubai
    Posts
    166
    Quote Originally Posted by samui View Post
    Thanks guys, This works well because it keeps other pressure? What do you think of Walbro pumps? hello all
    Walbros are great pumps. I do use one in my ski

  9. #9
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    Quote Originally Posted by waseemyah View Post
    Walbros are great pumps. I do use one in my ski
    +1 no problems with my walbro I installed last year.

  10. #10
    richrxp's Avatar
    Join Date
    Jun 2006
    Location
    Netherlands
    Posts
    949
    +1
    1
    Running walbro for some time now,no problems!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Why does my ski pull to the right
    By Dion in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-28-2014, 12:33 PM
  2. why does my ski "pull"
    By mattydipps in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 05-22-2013, 05:54 PM
  3. Replies: 2
    Last Post: 07-01-2012, 05:11 PM
  4. my jet ski starts but only when i prime it
    By mushroomhead8 in forum Polaris Open Discussion
    Replies: 9
    Last Post: 12-13-2008, 01:11 AM
  5. Does my ski have a limp mode?
    By carolinaz71 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-31-2008, 11:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •