Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1
    rxpsquad's Avatar
    Join Date
    Dec 2010
    Location
    birmingham UK
    Posts
    173

    seadoo rxp max out at 6500 rpm with WOT

    hi took my ski out today
    and it was maxing out at 6500 rpm's
    i was doing around the 8000 when i last used it
    i have had a stainless wear ring fitted that was running great
    but not to sure if i sucked anything up into it
    the pull off just seems to be poor
    i was wondering if the supercharger is slippping
    or if anyone else knows what could be the possible cause
    done 55miles on it today and the engine sounds good but just not pulling the top revs
    its not good when you get overtaken by everyone else on the water


  2. #2
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    Sounds like the SC clutch washers took a dump.. What year rxp is it?

  3. #3
    Stockrxp's Avatar
    Join Date
    Aug 2010
    Location
    texas
    Posts
    1,009
    +1
    1
    Check your intake hoses

  4. #4
    rxpsquad's Avatar
    Join Date
    Dec 2010
    Location
    birmingham UK
    Posts
    173
    cheers i will take a look at the hoses tomorrow
    the rxp is a 2005
    but it only had metal washers about 10hrs ago
    will check to see if i can spin the fins as well
    if i had the charger all torqued up when the new washers were added
    would it be right that it needs re torquing after they have bedded in for a few hours

  5. #5
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    6500 rpm is usually where it runs when there's no boost. Check your hoses like Stockrxp said for lose clamps.

  6. #6
    rxpsquad's Avatar
    Join Date
    Dec 2010
    Location
    birmingham UK
    Posts
    173
    Ok I took off the hose to the supercharger
    And found I can turn the fins with my fingers
    So I assume something is wrong with the charger
    Now I only had new metal washers about 10- 15 hrs ago
    I took out the oil filter as well and there was some metal in there but only dust size
    Nothing bigger at all
    So I am hoping nothing has come off the charger yet and gone into the engine
    Will be pulling the charger off tomorrow

  7. #7

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    who rebuilt your charger?

  8. #8
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    You might be lucky and your nut just came lose on the shaft. The unlucky scenario would be your washers are toast.

  9. #9
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    Quote Originally Posted by ou812 View Post
    You might be lucky and your nut just came lose on the shaft. The unlucky scenario would be your washers are toast.
    Or ever worse the nut comes off and totally destroys the motor. Pull that charger out and definitely see what's going on. Don't start or crank the ski till you do.

  10. #10
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Why would you continue riding 55 miles when there is a problem?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 Seadoo RXP Shutters/Vibrates at 3500 RPM
    By kdaily in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-26-2016, 11:48 AM
  2. 1996 gtx loses power at 6500 rpm
    By soogtxguy in forum 2-Stroke Performance
    Replies: 22
    Last Post: 07-12-2009, 08:24 AM
  3. 98 GSXL tops out at 6300 RPMs ...on a good day
    By d0n in forum 2-Stroke Performance
    Replies: 12
    Last Post: 08-11-2008, 05:29 PM
  4. maxing out at 7850 rpms
    By newskiier in forum 4-Tec Performance
    Replies: 23
    Last Post: 07-25-2008, 03:11 AM
  5. 99 GTX Ltd Cutting out at high RPM
    By Picturemn2 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 09-28-2007, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •