Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18

Thread: Name that noise

  1. #1

    Join Date
    Jan 2007
    Location
    Lakeland, FL
    Posts
    1,414

    Name that noise

    I'm cruising along the water at full throttle, and about every 5 to 10 seconds, there's a quick "chink" noise, and the RPMs immediately get knocked down a few hundred, but quickly build back to where they were. What could be happening? The sound can be heard from shore. I believe it happens as much on calm water as choppy. It only happens at full throttle.

    This occured before my rebuild on my stock ECU, and now it occurs the same after a full rebuild and a Riva ECU. I'm not hitting the limiter, just about 8400 for now. My SC slip is tight at about 160#s (also put in the '08 oiler mod during this build).

    I have a feeling that it has something to do with the pump... like it's overstuffing, or maybe some air is being introduced from under the boat or through the carbon seal. I replaced the seal, bellow and o-rings during this build too (tried to install the bellow band also, but it broke). Maybe my R&D grate isn't keeping the pump loaded?

    I can capture it on video this weekend, but wanted to get some initial thoughts.


  2. #2

    Join Date
    Jan 2007
    Location
    Lakeland, FL
    Posts
    1,414
    OK, so here's a video. From the shore, it just sounds like a little hickup, but I hear more of a metal "chink" sound inside the boat (probably the SC with the quick drop in RPMs). In this video, it happens at 1:22, at 1:52, at 2:10. Near the end at 3:00, it's from inside the boat looking at the tach... too much wind to really hear it, but you see it hitting about 8450rpms, then getting knocked down to 7500-7800 for a sec. As I said, it did this before the rebuild, now I basically have a new engine, and I changed out the carbon seal and bellow. My WOT AFR is set to 11.5. My best guess is it's cavitating with some air getting past the carbon seal every once in a while... does everyone agree, or have another idea of what it may be?


  3. #3
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    It sounds like your touching the rev limiter.. Slight unhook will let it rev just enough and happen so fast that your gauge won't show it in time..

  4. #4
    Huh? Dyoung's Avatar
    Join Date
    May 2009
    Location
    Pt. Neches , Texas
    Posts
    1,021
    +1
    25
    +1

    you're definitely banging the limiter on take off .....sounds like the same thing when you're running wide open too...just throwing this out there..how's the wear ring?

  5. #5

    Join Date
    Jan 2007
    Location
    Lakeland, FL
    Posts
    1,414
    Quote Originally Posted by Dyoung View Post
    +1

    you're definitely banging the limiter on take off .....sounds like the same thing when you're running wide open too...just throwing this out there..how's the wear ring?
    Stainless steel, new prop.

  6. #6
    ...Lighting The Water On Fire Since '04 duramaxxed's Avatar
    Join Date
    Jun 2008
    Location
    The Hamptons, Long Island, New York
    Posts
    790
    +1
    5
    Def. Sounds like the Limiter to me.

  7. #7
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    Sounds like limiter to me as well I would send that prop to speedrfreeks for some tweeking. She's banging that limiter too hardnoffmthe line... Or ur prop is chewed up already because of the ss wear ring. Man I hate those things

  8. #8
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    Never had ANY issues running the SS rings but thats a whole other topic.

  9. #9
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407

  10. #10
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    Quote Originally Posted by dnielsen View Post
    Never had ANY issues running the SS rings but thats a whole other topic.
    They are known for wearing the prop prematurly when u have lots of hp. I had to get my prop redone every season. Not now after ditching it

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Name that impellor (reward offered)
    By ATSAaron in forum Polaris Open Discussion
    Replies: 18
    Last Post: 04-20-2008, 12:33 AM
  2. Name That Part??
    By beerdart in forum Polaris Open Discussion
    Replies: 88
    Last Post: 05-22-2007, 11:00 AM
  3. Name that part - (aftermarket stuff)
    By ATSAaron in forum Polaris Open Discussion
    Replies: 1
    Last Post: 09-10-2006, 08:35 PM
  4. name that sig,,,,
    By HOSS in forum Sea Doo Open Discussion
    Replies: 35
    Last Post: 07-01-2006, 09:22 PM
  5. What was that noise??
    By Pistonwash in forum Yamaha Open Discussion
    Replies: 18
    Last Post: 02-10-2006, 06:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •