Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1

    Join Date
    Sep 2006
    Location
    coteau louisiana
    Posts
    190

    low voltage alarm

    Hey guys i posted this in my rebuild thread but had no help. I just recently rebuilt my 951 and got it running put a new battery in it and i am getting low voltage alarm. brought it home charged battery over night put back in ski still getting low voltage alarm i didnt have a chance before i left home to come back to work to check the voltage and all with a volt meter. any things you guys can help me with to narrow down. i think the stator is still charging the battery cause i rode it for a good hour and didnt have any problems. any suggestions would be awesome.


  2. #2
    warner0308's Avatar
    Join Date
    Apr 2011
    Location
    mchenry,il.
    Posts
    519
    +1
    3
    im not shure, but on my gsx 1999 it eats voltage regulators evrey 2 years. (using cheap ones) same thing 12 volt low warning.

  3. #3

    Join Date
    Sep 2006
    Location
    coteau louisiana
    Posts
    190
    prolly it right there will track it down when i get home. i know our older 951 DI had to change it before. wheres a good place to get one? most i am seeing are for 00-03 di motors and about 75 bucks/

  4. #4

    Join Date
    Sep 2006
    Location
    coteau louisiana
    Posts
    190
    I am also thinking my display is starting to go out the fuel lines on it are not showing up so i might need to find one like that soon.

  5. #5

    Join Date
    Sep 2006
    Location
    coteau louisiana
    Posts
    190

  6. #6

  7. #7
    warner0308's Avatar
    Join Date
    Apr 2011
    Location
    mchenry,il.
    Posts
    519
    +1
    3
    what year is yours and what is it? you never said? also dont laugh how do you guys get the ebay page on here like that? and yes one of them will work just dont know what you have

  8. #8

    Join Date
    Sep 2006
    Location
    coteau louisiana
    Posts
    190
    i have a 99gtxl carbed silver motor.

  9. #9
    canuck's Avatar
    Join Date
    May 2006
    Location
    The wet left coast.
    Posts
    1,097
    +1
    109
    Quote Originally Posted by sleblanc View Post
    Hey guys i posted this in my rebuild thread but had no help. I just recently rebuilt my 951 and got it running put a new battery in it and i am getting low voltage alarm. brought it home charged battery over night put back in ski still getting low voltage alarm i didnt have a chance before i left home to come back to work to check the voltage and all with a volt meter. any things you guys can help me with to narrow down. i think the stator is still charging the battery cause i rode it for a good hour and didnt have any problems. any suggestions would be awesome.
    Does the low voltage light stay on all the time or for a minute or so after starting then goes out ?

    The easiest way to check charging is to measure the battery voltage before starting then see if it jumps up slightly when the ski is running. These skis will go a long time if the battery is not being charged the draw when running is very low as they use magnetos for ignition and battery power is only used for the gauges and starting.

    I have a 98 GTXL and I always get the low voltage light for about a minute after starting then it goes out. If the 99 is the same as the 98 the voltage regulator is built into the MPEM.

  10. #10

    Join Date
    Sep 2006
    Location
    coteau louisiana
    Posts
    190
    stays on the whole time while running and the voltage on the battery actually jumps a little after starting like it should so it seems the stator is charging the battery.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 VX110 low voltage alarm
    By ilawns in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 08-11-2012, 11:24 AM
  2. Replies: 9
    Last Post: 05-03-2009, 10:11 PM
  3. 08 RXT X Low voltage warning
    By gobbles2700 in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 09-25-2008, 06:04 PM
  4. Low Voltage On Sppedster 200
    By racnanemesis in forum Sea Doo Sport Boats
    Replies: 11
    Last Post: 08-22-2008, 10:03 AM
  5. 06 RXP Low RPM's, Supercharger, Low voltage...
    By dcvet in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 06-16-2008, 09:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •