Results 1 to 4 of 4
  1. #1
    jheyde's Avatar
    Join Date
    Dec 2008
    Location
    Mansfield,OH
    Posts
    40

    06 RXT only pulls 7860-7900 rpms cavitation issues

    I'm at a loss here fellas. I've been battling this since last year. 06 RXT 116 hours, Riva CAI, Riva Intake Grate, stock prop, new wear ring, competition OPAS. She bangs the limiter off the line, and after 15-20 yards she grabs but won't go above 7900 rpms. I checked supercharger slip last year and it seemed fine. I did suck up a nasty rock last season and banged up some stator veins. I'll attach that pic, but I ground them as smooth as I can. My friends Yamaha FX160 is kickin' my can off the line, the cavitation is THAT bad.
    Below is a pic of the worst of that pump pain.....I have a Solas 14/19 I can chuck back in it, but I think this is something other than the prop. I had the stock prop refurb'd. The condition occurs regardless of prop. Pump seal looks okay, but then again, I guess I've never replaced it, and I don't exactally know what a bad one looks like? ANY suggestions fellas? I wanted to run a thru hull and an xs intercooler, catch can, and install the debris filter this summer, but if I can't get this under control with how it sits, there's no real point? I'm at a loss. Thanks for any advice guys.





    Click image for larger version. 

Name:	2011-07-12_17-17-32_630.jpg 
Views:	102 
Size:	60.0 KB 
ID:	267085


  2. #2
    jheyde's Avatar
    Join Date
    Dec 2008
    Location
    Mansfield,OH
    Posts
    40
    Oh yeah, and speedfreaks bellows band, new carbon seal and boot. The RPM thing is what kills me. If it's hitting limiter off the line, to me, it has to be cavitation.

  3. #3

    Join Date
    Jul 2007
    Location
    Montgomery, AL
    Posts
    257
    +1
    1
    Any water in hull? With that many hours could be carbon seal and boot. Look at hull under carbon seal and see if you have a black line. You can put zip ties around the accordian boot to increase pressure on carbon seal.

  4. #4
    jheyde's Avatar
    Join Date
    Dec 2008
    Location
    Mansfield,OH
    Posts
    40
    No water in the hull. I replaced the carbon seal and boot last summer and installed the bellows band. I'm at a loss. Ordering up another wear ring today and try that I guess. The wear ring may be one of those left over cheap ones off of Ebay that I bought a while back.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 11
    Last Post: 07-19-2011, 05:41 PM
  2. 06 RXT 8100 RPMs but only 60 km/h
    By dms1sds in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 06-02-2011, 11:00 PM
  3. RXT-X at Only 7900 rpm
    By EDondo in forum 4-Tec Performance
    Replies: 16
    Last Post: 06-16-2009, 08:26 PM
  4. RXT-X only getting to 6200 rpms
    By clouless in forum 4-Tec Performance
    Replies: 8
    Last Post: 01-09-2009, 12:24 PM
  5. Replies: 12
    Last Post: 10-11-2006, 01:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •