Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    Site Admin MikeTrin's Avatar
    Join Date
    Apr 2005
    Location
    Overland Park, ks
    Posts
    4,199
    +1
    51

    What's wrong with this picture?

    Can you tell what's wrong in these pictures. 2 pictures 2 views. It's from my 04 rxp. I think someone was drinking the day they assembled my ski.
    Last edited by MikeTrin; 03-28-2007 at 01:25 PM.


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    there is a paper towel stuck in your motor mike..Just messin with ya ..thought i would say it before someone else did..

  3. #3
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    im far from a mechanic but are the wires pinched behind the pto housing??

  4. #4
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    Some one busted a nut..I mean,,you know

  5. #5
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    i see were your looking at alex..is that were the SC mounts

  6. #6
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    Quote Originally Posted by Snoman View Post
    i see were your looking at alex..is that were the SC mounts
    Yeah, your SC has 3 bolts,I see two.

  7. #7
    Site Admin MikeTrin's Avatar
    Join Date
    Apr 2005
    Location
    Overland Park, ks
    Posts
    4,199
    +1
    51
    Yep, there's only 2 bolts holding my supercharger on!
    Last edited by MikeTrin; 01-13-2007 at 06:48 PM.

  8. #8
    mike, it could have been porosity and the mounting lug just snapped. or did it snap when you tried to unbolt it?

    either get a new PTO housing, and a oil pump at those hours or use JB weld, believ it or not when done properly it`s pretty strong...
    just ask Kinchyle!...PR...

  9. #9
    Site Admin MikeTrin's Avatar
    Join Date
    Apr 2005
    Location
    Overland Park, ks
    Posts
    4,199
    +1
    51
    Now that I rotated the picture I noticed the bolt at the bottom of the hull. It didn't snap when I was unbolting it but it seems to have snapped recently, how the heck do those things just snap like that.

  10. #10
    Quote Originally Posted by miketrin View Post
    Now that I rotated the picture I noticed the bolt at the bottom of the hull. It didn't snap when I was unbolting it but it seems to have snapped recently, how the heck do those things just snap like that.
    could be from vibration, cover could have been defective/porous and took all this time to fail, who knows! ...PR...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What is wrong with this picture
    By NCrunner2012 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 05-08-2016, 10:16 AM
  2. What's wrong with this picture???
    By UNSANE in forum High Performance Watercraft Safety
    Replies: 26
    Last Post: 07-24-2012, 02:46 PM
  3. What's wrong with this picture???
    By UNSANE in forum Southeast
    Replies: 29
    Last Post: 02-14-2012, 03:02 PM
  4. What's wrong with this picture?
    By Waveblaster in forum Honda Open Discussion
    Replies: 5
    Last Post: 10-13-2010, 07:52 PM
  5. What's wrong with this picture?
    By OsideBill in forum Yamaha Open Discussion
    Replies: 14
    Last Post: 12-04-2008, 07:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •