Results 1 to 4 of 4
  1. #1

    Join Date
    May 2011

    Instrument Gauge Died

    I have an 04 GTX SC awesome machine, about to get the sc rebuilt hopefully by Jerry and do some maintenance. But one thing that is really bothering me is that my instrument gauge died It was foggy for a little and than poof, no more. So here is two pictures. Im guessing there is no fix but if you have any ideas i would love to hear them, and btw this was a PITA to get out of its plastic casing... I guess ill buy a used one but they are expensive even than!

    Sorry for the huge pictures!

  2. #2
    Electronics Guru Alpheus's Avatar
    Join Date
    Aug 2010
    Northern,VA, United States
    I got one out of an 03 GTX that works. 50 bucks shipped...

  3. #3

    Join Date
    May 2011
    Can you send pm with a picture, mines an 04 GTX SC so i think that's the same

  4. #4
    Are there any signs of component burn?

    Put it in rice for a while.

    It draws out the moisture and may fix it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. instrument pannel help
    By yamahamike125 in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 06-09-2009, 02:29 AM
  2. 2003 GTX instrument gauge question
    By Chris0060 in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-31-2008, 09:21 AM
  3. Instrument Cluster
    By Jetsam in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 03-05-2008, 11:41 PM
  4. Instrument Panel
    By darcabre in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-30-2007, 11:54 PM
  5. Instrument Panel died...
    By darcabre in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-29-2007, 08:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts