Results 1 to 8 of 8
  1. #1
    BallaRXP's Avatar
    Join Date
    Oct 2010
    Location
    Clearwater, FL
    Posts
    86
    +1
    2

    Hard to Start RXP

    My '04 RXP has been hard to start for the last few months. Takes 2-3 attempts to get it to fire. Batt is good(12-12.4v). Did a voltage drop test on it yesterday. Voltage dropped down to 9 volts while cranking. Splashed it today, took 5+ attempts to get it to fire. After a short run I put it back on the lift, Go to flush it and it wont crank at all. Fuel pump runs, clicks(solenoid I assume) but does nothing. I am leaning towards a bad starter.


  2. #2
    jbombino's Avatar
    Join Date
    Jun 2007
    Location
    Hialeah, FL
    Posts
    636
    +1
    17
    Replace battery selenoid and recharge battery.

  3. #3
    BallaRXP's Avatar
    Join Date
    Oct 2010
    Location
    Clearwater, FL
    Posts
    86
    +1
    2
    Quote Originally Posted by jbombino View Post
    Replace battery selenoid and recharge battery.
    Where can I find the Batt Solenoid?

  4. #4
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by BallaRXP View Post
    Where can I find the Batt Solenoid?
    Should be right by the fuse box.

  5. #5
    oct6454's Avatar
    Join Date
    Sep 2008
    Location
    Gig Habor, Washington
    Posts
    758
    +1
    8
    On the 04's its a little brown plastic bow mounted next to the fuses....its mounted to the fuse bracket.

  6. #6

    Join Date
    Oct 2007
    Location
    NC
    Posts
    107
    Clean your spark plugs too! It never hurts

  7. #7
    BallaRXP's Avatar
    Join Date
    Oct 2010
    Location
    Clearwater, FL
    Posts
    86
    +1
    2
    Replaced the Solenoid today, Did not crank over. Its doing the same thing. Solenoid clicks but the starter will not engage to crank the engine over.

    What am I left to check? Starter? Fuses?

  8. #8

    Join Date
    Mar 2006
    Posts
    1,829
    +1
    119
    battery, cables and starter would be where I would look if you KNOW the starter solenoid is working correctly.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 Seadoo rxp hard to start on water
    By hunter2003k in forum 4-Tec Performance
    Replies: 18
    Last Post: 10-25-2013, 06:05 AM
  2. Replies: 12
    Last Post: 09-07-2013, 12:46 PM
  3. 2006 seadoo rxp hard to start 4 stroke
    By skigolfnut in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 08-14-2010, 02:19 PM
  4. Virage TX hard to start
    By pirate33 in forum Polaris How To & FAQs
    Replies: 23
    Last Post: 07-21-2007, 08:58 PM
  5. 97 SL 900 hard to start
    By S12L00X in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-15-2007, 06:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •