Results 1 to 3 of 3
  1. #1
    flipsfzr's Avatar
    Join Date
    Mar 2010
    Location
    melbourne australia
    Posts
    110
    +1
    5

    Really need some help here

    Ok.guys here's my situation. A few weeks ago I put a post up that I had an oil leak. Took it to the dealer and was told I need a another s/c. Anyway bought another one with riva gen 3 shaft put it together and took it out to test on the weekend . As soon as I got to about 6-6500 rpm oil light comes. on. Went back home had a.look and same thing. Got oil all in the air intake and i/c piping. Had a look at the s/c c and there is no way oil is escaping from the s/c. Must be oil coming into the intake side of things but can't locate from where yet. If anyone has any ideas. it would be a great help as my ski hasn't seen the water for 10 weeks and Im getting a bit frustrated


  2. #2
    Cam Caps... Take of your valve cover and make sure your caps on the end of your cams did not come out.

  3. #3
    mike1706's Avatar
    Join Date
    Dec 2008
    Location
    ,Florida
    Posts
    1,691
    +1
    16
    Quote Originally Posted by flipsfzr View Post
    Ok.guys here's my situation. A few weeks ago I put a post up that I had an oil leak. Took it to the dealer and was told I need a another s/c. Anyway bought another one with riva gen 3 shaft put it together and took it out to test on the weekend . As soon as I got to about 6-6500 rpm oil light comes. on. Went back home had a.look and same thing. Got oil all in the air intake and i/c piping. Had a look at the s/c c and there is no way oil is escaping from the s/c. Must be oil coming into the intake side of things but can't locate from where yet. If anyone has any ideas. it would be a great help as my ski hasn't seen the water for 10 weeks and Im getting a bit frustrated
    yes if you still have connected the oil breather hose to the air intake, you are going to see oil in the supercharger, and in the i/c piping, check the Cams Caps that is where the oil is coming from

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 27
    Last Post: 01-07-2011, 03:56 AM
  2. Need some help here....
    By ou812 in forum 4-Tec Performance
    Replies: 2
    Last Post: 12-23-2009, 11:44 PM
  3. I really need some help!!!
    By verrettej in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 08-08-2008, 12:44 AM
  4. Noobie here, really need some help
    By smokey212 in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-13-2008, 05:53 AM
  5. EFI guys i really need some help.
    By mikegpr03 in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-19-2007, 11:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •