Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Help with my new 04 MSX 150

    Hey guys,

    New to polaris skis but not to waverunners in general. I part them out regularly and have a couple seadoos and standups of my own.

    I am about to pick up a 04 MSX 150 and I wanted to hear everyones opinions on the deal and possible solutions to the problem its having. Basically hes saying it has over 100 hours on it and he had the motor redone last year. He is currently getting the oil and coolant mixing (dont know if its in the oil or in the coolant yet). Hes saying he believes the guy who did the motor overhaul set the boost too high on the turbo and blew the headgasket causing the issue. Ski still runs. I am getting it for a $1000. I figured I could fix it and keep or sell it as long as its not a cracked block. And if it is ill just part it out. Looks like on ebay at least the parts dont sell too often but the normal big parts go for big money. I guess its due to the limited quantities out there.

    You guys think this was a good deal? What steps should I take to locate the problem.


  2. #2
    Also I have dealt with this guy before. He is an honest guy I just wouldnt trust his mechanical knowledge.

  3. #3
    Polarisitis loonatik's Avatar
    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    812
    +1
    10
    Read up on link below and go with your guts feeling, I just don't think there're that many MSX 150 users left.
    http://polarispwcknowledge.shorturl....10-and-msx-150
    Last edited by loonatik; 03-27-2012 at 09:09 PM. Reason: Typos

  4. #4
    Redrum's Avatar
    Join Date
    Oct 2011
    Location
    Iron River, WI
    Posts
    161
    I am having a similar problem of where there seems to be water mixing in the oil. Some suggestions as to where I am going to be looking that you could look as well. The oil reserve tank should be able to hold some pressure if you pump a bit of air into it (I am guessing people are draining the oil and removing the tank when doing this?) If not, the oil task has water running through it in a separate loop that has a gasket between the oil and the water. That gasket might have gone bad. Could be the seals in the water pump, could the the oil cooler. These are suggestions I have found here so there are some places you could start looking.

  5. #5
    Thanks guys!

    Yea unfortunately I have been dealing with some issues but hopefully ill be out there after work today to at least get the compression test done and go from there. I have read about the stuff you mentioned Redrum and ill let you know what I find as well. Hopefully ill have some answers tonight.

  6. #6
    So I have 145 on back cylinder and 130 on front... Good numbers but aren't they suppose to be equal?

    Also when I start it up revs will rev up then sputter and then rev up again almost like it's missing

    I have milky oil as well... How do you check the coolant to see if there is oil in there

  7. #7
    Polarisitis loonatik's Avatar
    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    812
    +1
    10
    1. When on trailer, not in the water, DO NOT rev your MSX without first putting it in reverse!!!
    2. DO NOT run engines more than 5 seconds without water!!!

    Missing you heard because you're hitting rev limiter.
    Take some time going thru link I posted in my earlier reply, post #3. You'll find everything you need to know there.

  8. #8
    urugol's Avatar
    Join Date
    Nov 2009
    Location
    Sydney, Australia
    Posts
    1,231
    +1
    3
    Quote Originally Posted by loonatik View Post
    1. When on trailer, not in the water, DO NOT rev your MSX without first putting it in reverse!!!
    2. DO NOT run engines more than 5 seconds without water!!!

    Missing you heard because you're hitting rev limiter.
    Take some time going thru link I posted in my earlier reply, post #3. You'll find everything you need to know there.
    That's some good advice. Reverse limits your rpm to around 3K so you can't rev the nuts off the motor. Always turn on the engine first then the water to get started. To finish shut down the water before turning the engine off.

  9. #9
    Thanks

    I did read that before yesterday.. Good stuff btw.. I did have the ski in reverse when I did it.. Would it do the same hitting the reverse rev limiter? I didn't have it started more then 5 10 seconds

  10. #10
    So I have an update. I found the coolant tank... (dont laugh). Peaked in and there was no noticable oil sitting on top. Good sign.

    I also pulled both MAP sensors. No oil contamination there although I did find the bottom MAP sensor plug had one of the 3 wires slightly pulled out. I did my best to shove it back in and put the rubber boot back on it. May have to revisit that. No oil contamination in the hoses or throttle body. Im planning on taking the oil tank out and rigging something up to pressure test that. Hopefull this is my milky oil issue.

    Double checked the compression. 130 and 140. Check Engine light is blinking. When I start it it surges between like 1200 and 2500 RPM and it will die on its own before I have a chance to turn on the water. also sounds like it is popping or missing while its surging.

    Any advice would be appreciated

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help with my 2003 Polaris MSX 140!
    By R12Hill in forum Polaris Open Discussion
    Replies: 10
    Last Post: 07-25-2016, 11:01 PM
  2. Need help with my 2003 Polaris MSX 140!The
    By R12Hill in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-29-2016, 09:53 PM
  3. Need help with my (NEW to me) Wave raider 1100
    By needforspeed in forum Yamaha Old School Skis
    Replies: 5
    Last Post: 05-28-2015, 01:00 PM
  4. Replies: 12
    Last Post: 06-16-2009, 09:42 PM
  5. help with my new summer job
    By HallPass in forum Open Discussion
    Replies: 21
    Last Post: 04-16-2008, 11:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •