Results 1 to 10 of 10
  1. #1

    Just installed my new walbro GSS342 fuel pump to my RXP do I need to bleed it?

    Just installed my new walbro GSS342 fuel pump to my rxp do I need to bleed it? Tried starting it ,fires but doesn't continue running


  2. #2
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    It should prime itself, atleast mine did. What year is your ski? Full of fresh fuel? Might have to wire in a relay.

  3. #3
    Its a 2007 ,half tank of fresh fuel, thats what I would of thought ,it would have self primed,then I thought maybe an air lock??

  4. #4
    I put a separate hose ( into a gas can on the floor) onto the fuel feed on the pump to see if was pumping fuel ,put the lanyard on and nothing came out so I pulled it apart again put it back together and fired right up ?? cool!! got me worried though I'll stick close to shore for an hour or so, Now on the pump between the two filters theres a rubber and steel washer ,I guess like a non return type of valve?? ,how do you know if its all lined up alright?? so when you slide the pump back into the module that it all lines up, can it push up against the washer and holding it down closing it off ?? just wonder if thats where I went wrong the first time.

  5. #5
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    I didn't put the rubber or steel washer back in. It's not needed

  6. #6
    Thanks for your help jhill if it gets to be a problem I'll remove it thanks again

  7. #7
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    yes it is needed ... that is the check valve to keep the surge tank full
    if your low on fuel and shut off the motor the surge tank will drain down to the same level as the fuel tank at startup
    and will keep draining out and may never get full enough. with out a full tank you could suck some air and your fuel psi will drop fast and very low, very bad

  8. #8
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    Quote Originally Posted by skidoochris View Post
    yes it is needed ... that is the check valve to keep the surge tank full
    if your low on fuel and shut off the motor the surge tank will drain down to the same level as the fuel tank at startup
    and will keep draining out and may never get full enough. with out a full tank you could suck some air and your fuel psi will drop fast and very low, very bad
    Many others and I have been running without it for many hours with no issues.

  9. #9
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    it only takes 1 bubble to learn a expensive lesson

  10. #10
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by skidoochris View Post
    yes it is needed ... that is the check valve to keep the surge tank full
    if your low on fuel and shut off the motor the surge tank will drain down to the same level as the fuel tank at startup
    and will keep draining out and may never get full enough. with out a full tank you could suck some air and your fuel psi will drop fast and very low, very bad

    Correct,the little orange rubber gasket and washer are for your surge/emergency tank..As many do run without it,It is not a must,BUT it is recommend to run it.....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 09-20-2015, 11:30 AM
  2. Where does everyone buy there walbro gss342 fuel pumps from?
    By ModularJunk in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-23-2012, 08:50 PM
  3. WTB new three outlet Fuel pump for 94 SLT750
    By jarcynvicnchris93 in forum Polaris Classifieds
    Replies: 5
    Last Post: 07-10-2008, 10:12 PM
  4. Installing new 3 outlet fuel pump
    By sweetcoupe in forum Polaris Open Discussion
    Replies: 8
    Last Post: 05-25-2007, 09:43 AM
  5. Just installed my digital boost and A/F ratio gauges
    By Green Hulk in forum 4-Tec Performance
    Replies: 26
    Last Post: 01-25-2006, 06:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •