Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Join Date
    Feb 2012
    Location
    Uk.northwest
    Posts
    43

    2008 kawasaki 250x sudden drop in boost after full burst of throttle then slow build?

    can anyone help with my problem ,i have installed riva intake riva exhaust r&D waste gate block off also a skat trak 13/18 impeller,and now when i take off full throttle the ski redlines a bit as usaul but then it looses power drops to 2 thousand revs and builds back up ,my head is fucked with this now should i put all stock parts back on ?it seemed to start when i turned hard right i 1st thought it was fuel and filled my ski to full today and it seems the same it is as though i am in a powerfull car and the traction control is kicking in....i hate it now i carnt even have a race because as soon as i full throttle it takes of great then looses power then builds back up...HELP anyone please thanks in advance.


  2. #2
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Check your air intake for obstructions check your block off make sure it's sealed correctly for the waste gate. Check your sc belt tension.

  3. #3

    Join Date
    Feb 2012
    Location
    Uk.northwest
    Posts
    43
    Quote Originally Posted by FIRE0021 View Post
    Check your air intake for obstructions check your block off make sure it's sealed correctly for the waste gate. Check your sc belt tension.
    Thanks for reply mate , 1st of all it was doing this before I put block off plate I added plate today hoping to solve issue but it's still the same I have just took front off to remove fuel pump from tank incase it was clogged only a slight bit of debri nothing to suggest fuel starvation am puzzled even guy at Kawasaki dealer says it must be fuel as it would throw a fault code if any think else was the issue, am pissed off As I just filled tank thinking maybe low fuel and still doin it and now av had to empty it incase of shit in tank blocking up I haven't checked belt yet as I ran out sunlight and had to call it a day, and am presuming air intake is fine will check tomorrow but I know I can here a whoosh since installing it and my ski seemed really quick after install so am assuming its working ok

  4. #4
    ImpactSportsTV's Avatar
    Join Date
    Apr 2009
    Location
    San Clemente, CA
    Posts
    173
    +1
    16
    I think FIRE is correct pointing to the SC belt - I had the lower hose clamp of the exhaust coupler connecting the manifold elbow to the waterbox let go and it sprayed exhaust and water on the belt at WOT causing it to slip, very similar symptoms to yours. Perhaps something with the Riva exhaust install isn't right? Best of luck!

  5. #5
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    sounds like belt slip, or cavitation to me

  6. #6

    Join Date
    Feb 2012
    Location
    Uk.northwest
    Posts
    43
    Quote Originally Posted by ImpactSportsTV View Post
    I think FIRE is correct pointing to the SC belt - I had the lower hose clamp of the exhaust coupler connecting the manifold elbow to the waterbox let go and it sprayed exhaust and water on the belt at WOT causing it to slip, very similar symptoms to yours. Perhaps something with the Riva exhaust install isn't right? Best of luck!

    It's strange you should say that because it's ever since guys at lake installed my free flow exhaust I have noticed it and now it's getten a lot worse at first a couple weeks ago I thought fuel then after Getting air filter changed the other day I am noticing it a lot now,am gutted as a lot you guys have dun same mods with no messing from ski I on other hand have pissed about ordering my stuff from usa because of recent posts you guys have done and I seem jinxed I am most paranoid person when it comes to my ski,I cuddle it an no expense spared so when I get this happening I am gutted I am gunna order new belt tomorrow and get it changed ASAP and cross my fingers,my mate is gunna buy it in a few weeks and I shouldn't really bother but I want him to have a nice ski to keep up with us on days out so really need to fix this before I hand it over as my mate is bit dizzy and properly will run it into ground if I don't pester him to keep on top of maitanence,but while I have it I want perfection not hesitation....so I guess it's new belt and hope for the best....also any one ever felt inside ic after they take bov off? I did and it felt ruff as toast is that right or did old owner neglect and let salt do its nasty work ? I am going to remove and try clean if possible also read some gaskets on exhaust or is it the black thing across engine with supercharger on it leakes from a couple gaskets and could be cause? I did notice slight whitish kinda blow out of some kind at one the joins between gaskets ? Questions questions my heads swimming with them at moment surely some one knows what's what the ski is a 2008 I cannot be the only one

  7. #7

    Join Date
    Feb 2012
    Location
    Uk.northwest
    Posts
    43
    Quote Originally Posted by nicjak View Post
    sounds like belt slip, or cavitation to me
    I asked guy on lake that myself about the cavitation he seems to think it will be ok I see a lot put the shoe wedges in when guys on lake done my intake grate the just silicones it all up good and seeled he said and it was left for a few hours...it's a strange feeling say you come hard straight then digg a turn hard and try to power out and it normally redlines also still pushing hard well mine just bogs down after the hard turn and seems to struggle trying to build up as though fuel starvation ....like if tanks empty and you try to play a bit longer and you can feel every now then a slight drop in pressure that's what it feels like....the guys must think am crazy am making all humming noises trying to explain what it sounds like engine noises etc lol ...not good at all ...

  8. #8

    Join Date
    Feb 2012
    Location
    Uk.northwest
    Posts
    43
    Nicjak if the belt was slipping and I full throttle to get a good hole shot and the ski flies of the mark then ski dies then builds up would you say the belt is slipping?

  9. #9

    Join Date
    Feb 2012
    Location
    Uk.northwest
    Posts
    43
    Sorry if my spelling is off this iPad has a mind of its own

  10. #10

    Join Date
    Feb 2012
    Location
    Uk.northwest
    Posts
    43
    Stripped supercharger case today bolt tension seemed very loose as soon as I put tension on it,it began to move so I tightened up also I notice pit marks on the tension pulley so have just orded new one I still got the sudden loss of power after full power take off,also I noticed after I had digital display the revs ,that my revs shot up to 8250 maybe a bit more then all kinda confusion loss off power etc..then build up again strange sensation and not like a red line effect because it actually does a redline effect at first unless that's the pump surging what it can get then complete collapse of thrust ...am now starting to think after guy at lake installed new impeller and intake grate and just silicones it all up saying that's what they do in the factory is maybe the issue so I have orded pump seal kit incase my loss off power after initial full throttle and loss off power and rev drops is the ski trying to huck up again ....my heads in bits with this I hope it's something so simple as the pump kit as its only just started after I installed my mods and I cannot see these doin all this when surely some you guys would have had the same issues and I would of came across it before now..the guy at lake is now saying because I have a lot intake and out take goin on that my ski is Reving to its limit and shutting down some sort protection is he right are Kawasaki different do they collapse in revs if red lined to heavy unlike yams that's redline for fun with out any kind of abs traction control shit goin on ,or shall I do a rep itch to make the revs drop again ????

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts 2008 KAWASAKI 250X 260X Rear Seat Silver $60.00 shipped
    By Marineking in forum Kawasaki Classifieds
    Replies: 5
    Last Post: 06-11-2014, 09:36 PM
  2. 2008 kawasaki 250x ecu problem
    By bk250x in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 08-28-2013, 06:13 PM
  3. 2008 kawasaki 250x winterization......
    By priszm in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 09-21-2011, 10:52 AM
  4. FS 2008 Kawasaki 250X For Sale W/Full Factory Warrenty till 2013 10hrs on ski
    By andreasenracing in forum Kawasaki Classifieds
    Replies: 2
    Last Post: 01-03-2011, 12:56 AM
  5. FS 2008 Kawasaki 800 SX-R in Chicago
    By Cohiba262 in forum Kawasaki Skis
    Replies: 3
    Last Post: 10-27-2009, 01:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •