Results 1 to 10 of 10
  1. #1

    check engine light

    i have a 2005 rxp sc ic 4tec that when i start on the hose and let it run for a minute or two the check engine light comes on and will not give a code. i cant seem to find any thing in the manual about what to check when the check engine comes on did i miss it some where. thanks i did see the section on codes


  2. #2
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    stealership need to hook it up to buds or candoo

  3. #3
    really what a rip for a check engine light

  4. #4
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    yep, try hitting set 5 times to see if anything comes up

  5. #5
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by jhill19 View Post
    yep, try hitting set 5 times to see if anything comes up
    If there is a code, it will be present after the above. Might be a cooling issue if it happens when you are on the hose. What about your coolant level?

  6. #6
    no codes it does after about2 min on the hose

  7. #7
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by 4pinwink View Post
    no codes it does after about2 min on the hose
    Any audible noise?

  8. #8
    yes there is one audible noise or a beep then it says check engine across the display screen but no codes is this still a dealer thing it will run for about 2min on the hose. i can stop come back later try it again and it will almost do it at the same time first time was 2:38 second was 2:35 and the third was 2:41

  9. #9
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    If check engine light is coming on it should have a code.
    Are you sure your pushing the correct button.?

  10. #10
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Quote Originally Posted by 4pinwink View Post
    yes there is one audible noise or a beep then it says check engine across the display screen but no codes is this still a dealer thing it will run for about 2min on the hose. i can stop come back later try it again and it will almost do it at the same time first time was 2:38 second was 2:35 and the third was 2:41
    It sounds like a temp issue. That's about how long it takes for it to come on. The exhaust temp sensor or another internal sensor. As Skoepp stated, if the check engine light is coming on, THERE MUST BE A SUPPORTING CODE! When the ecu detects a value that is not within the 'safe' ranges, it notifies you with a check engine light. It is there. It has to be. You are best to take it in and have it hooked to buds and they will be able to read ALL of the codes and the history on the ski. Good Luck!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help, Check Engine Light, Error Code P0344
    By JC7727 in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-14-2007, 06:27 PM
  2. Check engine light
    By mooneyb91084 in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-20-2007, 12:26 PM
  3. Check engine light! Not pulling a code... HELP!!
    By Venator in forum 4-Tec Performance
    Replies: 10
    Last Post: 12-10-2006, 07:58 PM
  4. check engine light came on when i went down to sea level
    By macattack in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-01-2005, 02:00 PM
  5. Check Engine Light
    By meeper in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-27-2005, 04:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •