Results 1 to 5 of 5

Thread: GPRXP problem

  1. #1

    GPRXP problem

    hey guys i jus bought my gprxp n took it out to go ride it and as im pulling out a hear the motor acting a bit weird so i go to get on the gas and it starts to bog and lag i play with the throttle a bit and i get it to plane but it only getting to 5500 rpms and then it starts to bog again im new to this so i need u guys to help me out. any ideas? also i would let off the throttle and get on it quick and it would get to about 6100 rpms but the ski wouldnt move it stayed put. this is the second time i ride it the first was me testing it before i bought it and it ran perfect i got it to 8200 rpms with no problems or issues so i dont know what can be wrong...


  2. #2
    "Hustler" Inkaddict's Avatar
    Join Date
    Aug 2007
    Location
    NJ
    Posts
    4,714
    +1
    26
    We need to know more about your set up... What waterbox is in the ski? I blew the end cap off my box and had the same problem. Could also be a blown out sc, water ingestion, fouled plugs, etc... Could be many things...

  3. #3
    abarrassr07's Avatar
    Join Date
    Aug 2008
    Location
    Louisiana
    Posts
    424
    Quote Originally Posted by danielaguilar__ View Post
    hey guys i jus bought my gprxp n took it out to go ride it and as im pulling out a hear the motor acting a bit weird so i go to get on the gas and it starts to bog and lag i play with the throttle a bit and i get it to plane but it only getting to 5500 rpms and then it starts to bog again im new to this so i need u guys to help me out. any ideas? also i would let off the throttle and get on it quick and it would get to about 6100 rpms but the ski wouldnt move it stayed put. this is the second time i ride it the first was me testing it before i bought it and it ran perfect i got it to 8200 rpms with no problems or issues so i dont know what can be wrong...

    the engine revs up but the ski does not go anywhere? bad wear ring will do this, but none of the other things you have listed

  4. #4
    Quote Originally Posted by Inkaddict View Post
    We need to know more about your set up... What waterbox is in the ski? I blew the end cap off my box and had the same problem. Could also be a blown out sc, water ingestion, fouled plugs, etc... Could be many things...
    its pretty much a stock rxp setup im going to try n put up pictures, another thing is that i flushed it the wrong way i turned the water on before the motor and turned the motor off before the water<--noob mistake. but it still turned over and started right up after that but since then its been giving me this problem, it also gave me a code (po326) so i thot it was the knock sensor that was making it act up but i put a new one n it wouldnt give me the code anymore but i put it in the water n the same problem kept happening

  5. #5
    Autosport's Avatar
    Join Date
    Feb 2007
    Location
    In the Fast lane
    Posts
    1,586
    +1
    25
    Just as a quick check, take the two main connectors off the ECU & check for corrosion, the fact you've mentioned the knock sensor has me thinking wiring.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. gprxp afr problem
    By 2stroke-tech in forum Conversion PWC Performance Skis
    Replies: 4
    Last Post: 09-26-2016, 05:21 PM
  2. GPRXP Starting Problem
    By Tedcfitz in forum Conversion PWC Performance Skis
    Replies: 8
    Last Post: 08-14-2012, 06:45 PM
  3. gprxp fuel problems
    By bossplayer5 in forum Conversion FAQ and Tips
    Replies: 8
    Last Post: 07-13-2011, 11:42 PM
  4. Troubleshooting the Rotax Racing Stage I kit (was problems)
    By Jarrett in forum 4-Tec Performance
    Replies: 104
    Last Post: 10-22-2005, 08:12 PM
  5. 04 RXP Starting problem/question...
    By BLOWNRXP in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 06-01-2005, 10:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •