Results 1 to 3 of 3
  1. #1

    Join Date
    Jul 2011
    Location
    Wake Forest NC
    Posts
    22
    +1
    2

    05 FX HO Will Not Turn Over

    I am trying to de-winterize my ski. Put the battery, which had been on tender all winter, in the ski and hooked it up. When I hit the start button, the bilge runs for a short while, but no cranking. The dash display shows the usual 0 MPH and the gas gauge appears correct. When the bilge stops, the dash goes blank. No solenoid clicks or anything.

    The security, L mode and warning LEDs are all unlit. The ski ran fine when I dropped it off at the dealer to be winterized. I had asked them to program the remote, I had bought the ski used and it never worked. They stated that there was something wrong with the wiring harness and that they could not program the remote.

    Do you think they have somehow have gotten the thing in security mode?

    I took the battery to my local Advance Auto to be tested. They said it was good, showing 626 CCA (325 CCA AGM battery) and 13.03 volts.

    Thanks for your help.


  2. #2

    Join Date
    Jan 2012
    Location
    SoCal
    Posts
    111
    +1
    3
    Sounds like your 2005 dash is a little different than my 2007 ("Security" indicator instead of "UNLOCK"), but if it's unlit then it sure seems like it's not enabled, though what you're experiencing sure does sound like what happens when it's enabled.

    Any idea what they did while it was in their possession? Weird that they would say there's something wrong with the wiring harness to cause a problem with programming the remote and now the ski doesn't start... They had to have done something to determine that, I'd say it's on them to make it right but it may be hard to prove it was their fault since so much time has passed. Good luck, let us know if you get it sorted out!

  3. #3

    Join Date
    Jul 2011
    Location
    Wake Forest NC
    Posts
    22
    +1
    2
    Yeah, the ski was "locked". I was able to swap out the module from a 2007 FX HO donor ski and th 05 is up and running now. I'm still going to call the dealer to see if he can "unlock" the original security module.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. engine will not turn over
    By rayr in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-12-2010, 06:55 PM
  2. Motor will not turn over
    By aha in forum 4-Tec Performance
    Replies: 65
    Last Post: 04-11-2009, 02:39 PM
  3. HELP HELP will not turn over dead.
    By JOSE13RT in forum Yamaha PWC Performance (2-stroke)
    Replies: 17
    Last Post: 07-13-2008, 04:08 PM
  4. 2000 Polaris Genesis FFI will not turn over
    By maui in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 04-10-2008, 08:24 AM
  5. Jumped wave and GP 1200 died...will not turn over.
    By iam026tb4u in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 08-27-2007, 06:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •