Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    2009 Ultra LX surging intermittently.... any input welcome : )

    Hello all, My name is Jeremiah and I live in Alaska. I went and test ran my 2009 Ultra LX for the first time today. I bought it used. Its got around 25hrs on it.

    Ran great for about 2hrs, then all of a sudden, around 6500rpm the rpms would surge with around 500rpm intervals. No warning lights came on at any time while riding.

    The problem would go away momentairly if shut down and let sit for a couple minutes. The surging got worse as i rode back to the harbor. Started happening at all rpms. I had to repeatedly shut down and restart to make it back. Runs PERFECT until it starts surging....

    The problem DOES happen with both the yellow and orange keys.

    I am an experianced automotive technician, however, ignorant to the electronics and common issues with these specific PWCs.

    Any help, similar experiences, or shots in the dark would be very much appreciated!

    Thanks and good riding!

    Jeremiah

    p.s. My friend was riding my other Ultra LX at same time. Both fuel tanks were filled with the same fuel and have similar hours on them. Rules out fuel caused issues.....


  2. #2

    Join Date
    Jan 2012
    Location
    Homer, AK, D.F., MEX., Now San Antonio, TX
    Posts
    1,420
    +1
    154
    Jeremiah, there are a couple of knowledgable guys probably going to come on and help you. I can't (I'd be guessing when I said "air leak in the fuel system"). I'm down in Homer, where are you riding already? - There's cars on my lake still!

  3. #3
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    surging or a miss?

  4. #4
    Mark - We rode in Whittier down to the Port Nellie Juan

    nicjak - It is surging. started happening in 500rpm ups and downs. As it got worse it was greater rpm swings. I have felt cars do similar things when there was a bad TPS sensor. Do these have throttle position sensors? Think that might be the culprit?

    Thanks everyone!

  5. #5

    Join Date
    Jan 2012
    Location
    Homer, AK, D.F., MEX., Now San Antonio, TX
    Posts
    1,420
    +1
    154
    Cool. Should be nice this time of year. Good luck with your surge.
    BTW, those should be good Wetdog skis...

  6. #6
    Whittier was quite nice. Got some great footage of some porpoises swimming along with us for 3-4 minutes. A little odd feeling being the only ones on the water/

    The Ultra LXs would be nice "Wetdog" skis.... if it ever happens I am doubtful that we will ever see an endurance race of that caliber, mainly due to the safety risk, and the almost guarantee of deaths. I have heard that the USCG is trying to put a stop to it before it ever begins. I think some WA to AK races would be more realistic and still be able to have the longest endurance race on record.

    So is there not that many Ultra LX riders on this forum? Is it possible that i am the only one experiencing this issue?

    Thanks!

    Jeremiah

  7. #7
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    Yes there is a tps on the ski.

  8. #8
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Did u change the plugs yet ?

  9. #9
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    Quote Originally Posted by UltraAK View Post
    Whittier was quite nice. Got some great footage of some porpoises swimming along with us for 3-4 minutes. A little odd feeling being the only ones on the water/

    The Ultra LXs would be nice "Wetdog" skis.... if it ever happens I am doubtful that we will ever see an endurance race of that caliber, mainly due to the safety risk, and the almost guarantee of deaths. I have heard that the USCG is trying to put a stop to it before it ever begins. I think some WA to AK races would be more realistic and still be able to have the longest endurance race on record.

    So is there not that many Ultra LX riders on this forum? Is it possible that i am the only one experiencing this issue?

    Thanks!

    Jeremiah
    First- I am with Fire, check your plugs.
    Secondly. The inland passage is a dream ride of mine. If that were to every come together I would do all I could to make it up for that one.

  10. #10
    Quote Originally Posted by FIRE0021 View Post
    Did u change the plugs yet ?
    I have not changed the plugs yet. Maybe my thought process is incorrect, but I figured spark plugs would cause the issue to happen all the time. Being that this problem is intermittent, thought maybe a sensor.

    I will try running it on the hose and see if I can get it to duplicate.... then swap plugs and see if that corrects it. Got my hands on a service manual... gonna scope the TPS sensor and see what it reads out.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. help with brand new ultra lx 2013 intermittent starting problem
    By danf1000 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 04-01-2013, 10:02 PM
  2. 2008 Ultra Lx surging
    By Flyguyphl in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 07-14-2012, 11:15 AM
  3. 2009 Ultra LX 260 - not stable - need more boyant sponsons?
    By CleanLivin in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 07-10-2010, 07:27 AM
  4. WTB 2007-2009 Ultra LX Black Seat
    By kman in forum Kawasaki Classifieds
    Replies: 0
    Last Post: 04-22-2010, 07:00 AM
  5. Any Ultra LX Mods done?
    By Brewer3 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 05-27-2007, 10:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •