Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 33
  1. #1
    Sayers's Avatar
    Join Date
    Jul 2010
    Location
    Melbourne AUS
    Posts
    2,300
    +1
    134

    Flywheel Bolt failures

    Yesterday my flywheel must have been hungry because it ate my stator!


    Ski instantly died then could hear the starter but nothing turning over. Was sure at that point that I'd expect to see a timing chain or flywheel bolt failure.
    got home pulled the valve cover, was very happy to see the chain still on. Pulled the PTO and no surprise all bolts sheered off.

    engine build date is 01/2006.
    It's well known that 04-05 had issues with these bolts and upgraded ones were installed on 06+. Does anyone know the exact date Rotax started using the upgraded bolts? Is there anyway to tell which bolts they were?

    Is this common on 06+ skis? How many out there have had this issue?

    Thinking I'll be installing some 10mm ARP purpose made flywheel bolts.



  2. #2
    What was the rpm you were running at the time?

  3. #3
    Sayers's Avatar
    Join Date
    Jul 2010
    Location
    Melbourne AUS
    Posts
    2,300
    +1
    134
    Quote Originally Posted by pandan9 View Post
    What was the rpm you were running at the time?
    8550

  4. #4
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,072
    +1
    790
    Make dang sure you clean out everything. Cases and all. As that crap flows everywhere in a failure. I had two skis in that did this and they both ate rod bearings after the dealer did a crapy job on fixing them. Split cases and flush every port. And inspect/replace oil pumpsand timming chain.

  5. #5

    Join Date
    May 2005
    Location
    Minneapolis
    Posts
    763
    +1
    26
    Those look like the updated - original were stainless - updated are coated with a flange head. I don't know why a grade 10 metric bolt wouldn't work - Clean it all out +1

    Tim

  6. #6
    Sayers's Avatar
    Join Date
    Jul 2010
    Location
    Melbourne AUS
    Posts
    2,300
    +1
    134
    Quote Originally Posted by Water4fire View Post
    Make dang sure you clean out everything. Cases and all. As that crap flows everywhere in a failure. I had two skis in that did this and they both ate rod bearings after the dealer did a crapy job on fixing them. Split cases and flush every port. And inspect/replace oil pumpsand timming chain.
    What years were they?

  7. #7
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    That sucks!! I bet copper winding went everywhere!!

  8. #8
    Sayers's Avatar
    Join Date
    Jul 2010
    Location
    Melbourne AUS
    Posts
    2,300
    +1
    134
    Quote Originally Posted by GOLD06RXP View Post
    That sucks!! I bet copper winding went everywhere!!
    Yes and no. As soon as it chucked it the engine shut down. There was no horrible sounds when it happened. Screens are clean, don't think it really had a chance to pump much out of the PTO area.

    Dont take that the wrong way we all know it needs to be stripped down and flushed.

  9. #9
    hero's Avatar
    Join Date
    Feb 2011
    Location
    Australia sydney
    Posts
    331
    damn just when easter is around the corner hope u get it fixed intime....im heading out to dans racing tomorrow ill ask him for a stater

  10. #10
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    Damn brother, what a bad way to start out the season! It would be nice to know at what point in 06 did BRP find the problem and switch bolts. I have an 06 and would really like to know! I hope you get it sorted out soon....

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 24
    Last Post: 05-07-2015, 11:33 AM
  2. Tip of the day: flywheel bolts on 03-05 models
    By Green Hulk in forum Sea Doo How To & FAQs
    Replies: 37
    Last Post: 12-28-2007, 09:49 AM
  3. Thinking flywheel bolts sheared 20 min ago..
    By 9secZO6 in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-04-2007, 12:23 PM
  4. My Flywheel Bolt BREAKAGE story
    By sr71bb in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-22-2007, 02:28 PM
  5. Flywheel bolts
    By gerhand44 in forum Polaris How To & FAQs
    Replies: 21
    Last Post: 11-08-2006, 01:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •