Results 1 to 2 of 2
  1. #1

    cooling problems help needed please..

    water tested my 1990 sx550 black engine yesterday with guy who wants to buy it, but noticed there was no water coming out of the pisser on the side,
    so pulled the pipe off where enters from pump are theres water then pulled the pipe from top of engine and no water.
    can anyone please give me some help. starting to give up on this old ski now.. thanks justin..

  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Sounds like there is debris in there somewhere (obviously). See if you can get a flexible cable (like a speedometer or tachometer cable) and feed it through the hoses. You can even use an electric drill to spin it while you work it through the hoses.

    A lot of people try to blow the hoses out with compressed air, but you can split a plugged hose by doing that.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1988 JS 440 Problems, Help needed!
    By snox333 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-09-2011, 08:47 AM
  2. RTH needed - SS vs Aluminum pump parts - cooling tube length?
    By SoCalPaul in forum Polaris Open Discussion
    Replies: 5
    Last Post: 08-20-2010, 10:44 PM
  3. Single cooling vs Dual cooling? You thoughts please
    By NJJer in forum Yamaha Old School Skis
    Replies: 20
    Last Post: 11-17-2009, 10:03 PM
  4. Cooling Problems on Gp1300r
    By priest6479 in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-19-2008, 07:06 PM
  5. 1992 Polaris SL 650 cooling problems again
    By chazdo2 in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-14-2008, 08:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts